Visiting the Natwest Banking Login Page causes Firefox to hang temporarily

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: sam, Unassigned)

Tracking

41 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150923042249

Steps to reproduce:

Visit http://natwest.co.uk and click "Log In" at the top-right.


Actual results:

Firefox as a whole hangs temporarily, for about 30 seconds. Everything seizes, including the spinning loading icon on the problem tab itself. Minimising the window and resuming it just causes Firefox as a whole to be fully grey until it catches up and everything runs fine again. If you attempt to click the 'X' to close the hung tab nothing happens until Firefox catches up, and it then closes the tab.

The Firefox process munches up 100% of one of my cores whilst this is going on.


Expected results:

The page should load up ready to take my customer details. This issue does not happen on other browsers, such as Opera. This suggests it isn't a browser issue as such, unless Natwest are doing something wild in their web-page that Opera ignores and Firefox tries to process.

Comment 1

3 years ago
¡Hola Sam!

Following your steps I end up at https://www.nwolb.com/default.aspx this page contains a Flash element that I've blocked as described on https://support.mozilla.org/en-US/kb/set-adobe-flash-click-play-firefox

Does the hang goes away if you set Flash to click-to-play or uninstall Flash altogether?

¡Gracias!
Flags: needinfo?(sam)
(Reporter)

Comment 2

3 years ago
Hello,

Thanks for the useful response. I checked in my Add-On's but Flash isn't there suprisingly... I did have Chrome-Pepper-Flash but I've removed it and restarted, but that didn't solve it. Could you help me figure out where my flash is installed from/to? Is there a special about:: tab I can use to see what Firefox is using for flash?

What I did that did get it to work is use NoScript to disable scripts on Natwest, which worked!

Thanks!
Flags: needinfo?(sam)

Comment 3

3 years ago
¡Hola Sam!

Try about:plugins

I'm marking this invalid for now as it does not look like a bug to me for now.

¡Gracias!
Alex
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

3 years ago
Hi Alex,

Nothing there about Flash I'm afraid. I may have installed it somewhere system-wide or home directory using the old binary installer method, is there any easy way to check?

Thanks

Comment 5

3 years ago
¡Hola Sam!

Try with http://occupyflash.org/#resources

Let us know how it goes.

¡Gracias!
Alex
Flags: needinfo?(sam)
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 6

3 years ago
I had a look at the instructions and apparently I don't have Flash :| Since it is not in that location! Very confused now and not sure how to debug further. That site you linked to also said "you're not running flash, congratulations" etc. Very confusing.
Flags: needinfo?(sam)
You need to log in before you can comment on or make changes to this bug.