memory usage high very high

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: dgmurdockiii, Unassigned, NeedInfo)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8668278 [details]
memory-report.json.gz

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150928102225

Steps to reproduce:

use youtube with html 5 or other flash heavy sits or have many tabps open and im on on windows 10 build 10547 with the new memory magement if that make a difference alos here links to info on how it now works in current test build

https://www.thurrott.com/windows/windows-10/2062/microsoft-explains-os-compression-in-windows-10
http://www.winbeta.org/news/microsoft-educates-insiders-windows-10-handles-memory


Actual results:

when using flash or more than 5 six tabs or open 


Expected results:

shold not uses as much memory as it dose as it slows my computer to a crawl as im on windows 10 build 10547

Comment 1

2 years ago
Hi reporter, 
unfortunately this report is not very useful because it does not describe the problem well. If you have time and can still reproduce the problem, please read https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines and add a more useful description to this report by providing exact and clear steps (testcases!) to reproduce. "Open some pages" is not a testcase. :)
Flags: needinfo?(dgmurdockiii)
(Reporter)

Comment 2

2 years ago
just happens when i am using flash if i force end flash the the problem gose away
Flags: needinfo?(dgmurdockiii)

Comment 3

2 years ago
Setting needinfo as per comment 1
Flags: needinfo?(dgmurdockiii)

Comment 4

2 years ago
¡Hola Nicholas!

Does the attachment on https://bugzilla.mozilla.org/show_bug.cgi?id=1210297#c0 quacks like a bug to you?

Kindly let me know if you're not the person for MemShrink anymore.

¡Gracias!
Alex
Flags: needinfo?(n.nethercote)
The memory reports don't look unusual. Memory usage is over 1 GiB but there are lots of tabs open, so that's to be expected.

The reporter is assuming that the slowness is caused by memory usage but it's not clear that is true.
Flags: needinfo?(n.nethercote)

Comment 6

2 years ago
(In reply to dgmurdockiii from comment #2)
> just happens when i am using flash if i force end flash the the problem gose
> away

Given the root cause of the issue seems to be Flash, I'd suggest you to uninstall it altogether as detailed on http://kb2.adobe.com/cps/141/tn_14157.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.