Closed Bug 1210359 Opened 4 years ago Closed 4 years ago

check_stdcxx error messages are lacking context.

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox44 fixed)

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: nbp, Assigned: glandium)

Details

Attachments

(1 file)

Today, while trying to build Gecko locally, I got the following error message:

 1:30.69 libxul_s.a.desc
 1:30.72 libxul.so
 2:46.28 TEST-UNEXPECTED-FAIL | check_stdcxx | We do not want these libc symbols to be used:
 2:46.28   memcpy@GLIBC_2.14
 2:46.28 […]/config/rules.mk:826: recipe for target 'libxul.so' failed

which is quite a mystery, as I have no idea from where this symbol is coming from.  I have no idea which function / code / library introduced this symbol and have no clue where to start investigating.

A part from that, a link to some documentation would be nice, so that we can know what to do when these error message pop up to prevent a build.
I guess adding "version" after "symbols" would make it clearer that we don't actually care about the symbol itself. In your case, the problem is you're building against a libc that is too recent.

You're not supposed to use --enable-stdcxx-compat anyways.
Assignee: nobody → mh+mozilla
Attachment #8668706 - Flags: review?(mshal)
Attachment #8668706 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/37bc093b6a78
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.