[PDF Viewer] Dotted line partially rendered (some dots are missing) in PDF with HWA disabled

RESOLVED FIXED in Firefox 46

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Gerry Del Fiacco, Unassigned)

Tracking

unspecified
Firefox 46
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8668432 [details]
Analysis of Covariance.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

I opened the pdf document with Mozilla.  I am using Mozilla 40.0.3.


Actual results:

The page of the document that contains the graph in question does not display an important element of the graph.


Expected results:

The graph consists of a scatter dot chart on which three trend lines are superimposed.  The scatter dot pattern is displayed by Mozilla but the three trend lines are not displayed by Mozilla.  The graph in question is on page 5 of the attached pdf document.
Seems to work here, fwiw.
Component: Untriaged → PDF Viewer
Product: Core → Firefox
This looks like it may be a tiling or masking issue, but needs some further investigation.
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering]
(Reporter)

Comment 3

2 years ago
The pdf document was originally a Microsoft Word document that was converted to pdf using Adobe Acrobat.  When the document was created in Microsoft Word, the graph was constructed as a scatter dot diagram using Excel.  Then, the three trend lines were superimposed on top of the scatter dot diagram.
I couldn't reproduce with Nightly 45.0a1 and 42.0 RC under Win 7 64-bit. All three dotted lines are displayed.
(Reporter)

Comment 5

2 years ago
Many thanks for the research and comments.  I have been using an older level, namely, 40.0.3.  So, I should probably upgrade to a more current level.

Comment 6

2 years ago
Created attachment 8700671 [details]
Analysis of Covariance.5.pdf

The issue appears with HWA disabled only. I tested with FF40, indeed, the dotted lines are missing. In FF43/46, they are visible but not continuous, some dots are still missing.

Comment 7

2 years ago
Created attachment 8700672 [details]
screenshot-ff40-46.png

Comment 8

2 years ago
Well, the dotted line was visible in the past, it regressed with FF21:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=04e13fc9dbff&tochange=fcf79680a057
I suspect this bug:
Matt Woodrow — Bug 831529 - Stop using SkPath::contains for now since it doesn't match the canvas spec. r=jrmuizel

After that, it has been partially fixed since FF42 by Bug 1002466:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=efcc25c8a97f5abd653ebe4a7c8b177e3644de0d&tochange=74399f9da0e521f8725901478e6b5107b26f3e59
Flags: needinfo?(matt.woodrow)
Summary: I have a pdf document with a complex graph. Adobe Acrobat Reader displays this graph correctly. Internet Explorer displays this graph correctly. → [PDF Viewer] Dotted line partially rendered (some dots are missing) in PDF with HWA disabled

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Lee is looking at issues with skia rendering at the moment.
Flags: needinfo?(matt.woodrow) → needinfo?(lsalzman)
I am not able to reproduce this at all using Skia on Windows or Linux on nightly.
Flags: needinfo?(lsalzman)

Comment 11

2 years ago
Yes, it's fixed in Nightly.

Working range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d8e260e1535f0ff3877b21d6846380dedf449453&tochange=6630a176477ef903dcf3057db755abc43ba5018d

Bug 1082598
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Depends on: 1082598
Resolution: --- → FIXED

Updated

2 years ago
Target Milestone: --- → Firefox 46
You need to log in before you can comment on or make changes to this bug.