Closed Bug 1210411 Opened 7 years ago Closed 7 years ago

Large black/unrendered areas of webpages on pages that scroll more than 2 viewports in height

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jaws, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [fixed via backout of bug 1208636])

Attachments

(1 file)

I've seen this now on multiple pages. I'm running Nightly 2015-10-01 on Windows 10, and didn't see it with 2015-09-31.

Graphics
Adapter Description	Intel(R) HD Graphics Family
Adapter Drivers	igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
Adapter RAM	Unknown
Asynchronous Pan/Zoom	wheel input enabled
Device ID	0x0a16
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10547.0)
Driver Date	8-31-2015
Driver Version	10.18.15.4281
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	221817aa
Supports Hardware H264 Decoding	Yes
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Attached image Screenshot
APZ issue?
Quite possibly, yeah, but a regression window would be good since I don't think anything major APZ-related for windows landed between 09-31 and 10-01.
Used mozregression and narrowed it all the way down to https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d51440cc7a2fd9615d7d46bc36d67353d01b534e&tochange=aa61d48eb6ae747a5a755fb6996669720124a0d9 which only shows bug 1208636.
Blocks: 1208636
Flags: needinfo?(mchang)
Flags: needinfo?(bugmail.mozilla)
I'll be on PTO for a week or so (almost right after I type this message!). Making the displayport bigger shouldn't have caused this unless there is an underlying APZ issue? This seems odd. If you can't think of anything :kats, feel free to backout bug 1208636.

@Jared - Do you have a sample site that you can reproduce this with?
Flags: needinfo?(mchang) → needinfo?(jaws)
I can reproduce it with https://bugzilla.mozilla.org/show_bug.cgi?id=450322. I'm gonna back it out locally and see if that fixes it for me.
Flags: needinfo?(jaws)
I'll be on PTO starting next Tuesday for a couple of weeks and I don't think I have the cycles to chase this down before then - so if the backout fixes it for you please go ahead and land it. Mason or I can track it down when we get back.
Flags: needinfo?(bugmail.mozilla)
I've confirmed via local backout that the patch in bug 1208636 introduced this regression.
Backed out in https://hg.mozilla.org/integration/fx-team/rev/18960b8cb8e2 and reopened bug 1208636.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed via backout of bug 1208636]
You need to log in before you can comment on or make changes to this bug.