Closed Bug 1210442 Opened 5 years ago Closed 5 years ago

Support readOnly option in SyncEngine and DataAdapters

Categories

(Firefox OS Graveyard :: Sync, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
FxOS-S8 (02Oct)

People

(Reporter: mbdejong, Assigned: mbdejong)

References

Details

Attachments

(1 file)

Follow-up to bug 1209934
Assignee: nobody → mbdejong
Depends on: 1209934
Attachment #8668903 - Flags: review?(ferjmoreno)
Blocks: fxos-sync
Target Milestone: --- → FxOS-S8 (02Oct)
Attachment #8668903 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/41b8d96048170e9a16f1e98e46126a918c6517ac
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
(In reply to Sean Lee [:seanlee] from comment #3)
> In history.js, I see 'bookmarks' string:
> https://github.com/mozilla-b2g/gaia/pull/32204/files#diff-
> 4d73ff90f2479c9b5d1f53457e85e25dR276

I updated https://github.com/michielbdejong/gaia/tree/1200539-sync-app-integration-tests/apps/sync/#trying-out-the-sync-app to console.log the arguments with which DataAdapter#update is called, and could not reproduce your problem. Can you test on that branch?
You need to log in before you can comment on or make changes to this bug.