Transferring contacts via NFC does not work

VERIFIED DUPLICATE of bug 1204829

Status

VERIFIED DUPLICATE of bug 1204829
3 years ago
3 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8668597 [details]
logcat receiving

Description:
If the user sends a contact through NFC a blank page will appear with commands that suggest there should be a contacts list to import. but there are no contacts to import in this list.

Prerequisite:
Have 2 phones with NFC turned on.

Repro Steps:
1) Update a Aries to 20151001114357
2) Open the contacts app
3) Select a contact or make a new one
4) Hold 2 phones together anf slide the contact up to send it through NFC
5) Observe screen on receiving phone

Actual:
The user does not receive the contact through nfc

Expected:
It is expected that the user is able to receive the contact sent through NFC

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20151001114357
Gaia: bd8ff00faac97ad6a2df5a6217910b8d295d56a3
Gecko: 2c1fb007137dcb68b1862a79553b53f1a34c99c3
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
See attached: video clip, logcats
(Reporter)

Comment 1

3 years ago
Created attachment 8668598 [details]
logcat sending
(Reporter)

Comment 2

3 years ago
This issur DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20151001030229
Gaia: bd8ff00faac97ad6a2df5a6217910b8d295d56a3
Gecko: 096c0f407f8ba3ef7cfe4e0b831761993cac38b1
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
The user does not receive the contact through nfc
------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20151001032503
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 5a8574453182
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The contact sends correctly through NFC
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(ktucker)
Keywords: regression
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: sleedavid
Functional regression, blocking.
blocking-b2g: 2.5? → 2.5+

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204829

Updated

3 years ago
Assignee: nobody → jthomas

Updated

3 years ago
Assignee: jthomas → nobody
QA Contact: sleedavid → jthomas

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Contact: jthomas
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.