Refresh Firefox (Reset Firefox) should ask for confirmation

RESOLVED DUPLICATE of bug 881199

Status

()

Toolkit
Startup and Profile System
--
enhancement
RESOLVED DUPLICATE of bug 881199
3 years ago
3 years ago

People

(Reporter: NetVicious, Unassigned)

Tracking

(Blocks: 1 bug, {dataloss, ux-error-prevention})

41 Branch
dataloss, ux-error-prevention
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

When starting Firefox it detected some failure and shows a little window with two buttons: Safe Mode and Reset.

That reset button was bad translated to my language (was translated as Restart) and after clicking it Firefox deletes all the profile reseting all like a new instalation.

That's not a trivial action to run it from a simple button and it could destroy valuable stored information in the user profile.

IMHO when we press that button we should get a new window asking if we're sure of doing that action with a checkbox. If we mark that checkbox the OK button will be enabled for doing the full reset of the profile.
(Reporter)

Updated

3 years ago
Severity: normal → enhancement

Comment 1

3 years ago
(In reply to NetVicious from comment #0)
> That reset button was bad translated to my language (was translated as
> Restart)

What language?

> after clicking it Firefox deletes all the profile reseting all
> like a new instalation.
> 
> That's not a trivial action to run it from a simple button and it could
> destroy valuable stored information in the user profile.

The data isn't deleted. It's placed on the desktop, in a folder named Old Firefox Data.
https://support.mozilla.org/kb/recovering-important-data-from-an-old-profile

> IMHO when we press that button we should get a new window asking if we're
> sure of doing that action with a checkbox. If we mark that checkbox the OK
> button will be enabled for doing the full reset of the profile.

In en-US, clicking the “Refresh Firefox…” button under about:support brings up the following dialog. Was this information missing in the dialog box you got?


Refresh Firefox

  Start fresh to fix problems and restore performance.
  This will:
    Remove your add-ons and customizations
    Restore your browser settings to their defaults

[ Refresh Firefox ]  [ Cancel ]
Component: Untriaged → Migration
Flags: needinfo?(NetVicious)
OS: Unspecified → All
Hardware: Unspecified → All
Summary: Reset firefox → Refresh Firefox (Reset Firefox) should ask for confirmation
(Reporter)

Comment 2

3 years ago
Sorry, my language it's spanish

No, the dialog only had two buttons, one for start in safe mode and the bad translated "restart".

It seems Firefox detected one problem somewhere and cannot start correctly, so it suggested me to start from zero, or start without plugins/extensions.
Flags: needinfo?(NetVicious)

Comment 3

3 years ago
(In reply to NetVicious from comment #2)
> No, the dialog only had two buttons, one for start in safe mode and the bad
> translated "restart".
> 
> It seems Firefox detected one problem somewhere and cannot start correctly,
> so it suggested me to start from zero, or start without plugins/extensions.

That dialog prompt is triggered by a crash at startup.

> Sorry, my language it's spanish

Thank you for the update. es-AR and es-CL are okay. Filed reports for
es-ES: bug 1211860.
es-MX: bug 1211863.
Blocks: 851364
Keywords: dataloss, ux-error-prevention
(Reporter)

Comment 4

3 years ago
Thx, that's the dialog yes.

I saw the en-GB translation and for a newbie the Refresh button won't give him so much information about that critical action. So that it's why I suggested to add a new dialog before refreshing Firefox giving the user more information about what's the refresh.

Thanks for the info about the desktop folder with my old profile.

Marking as resolved.

Regards,
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1211860

Comment 5

3 years ago
(In reply to NetVicious from comment #4)
> Thanks for the info about the desktop folder with my old profile.

You're welcome. Bug 921462.

> *** This bug has been marked as a duplicate of bug 1211860 ***

This requests additional confirmation before the profile is refreshed. It's a duplicate of bug 881199, not one of the translation errors.
Component: Migration → Startup and Profile System
Product: Firefox → Toolkit
Duplicate of bug: 881199
You need to log in before you can comment on or make changes to this bug.