Closed Bug 1210749 Opened 5 years ago Closed 4 years ago

NS_ReleaseOnMainThread and NS_ProxyRelease should take already_AddRefed instead of smart pointers

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1164581
Tracking Status
firefox44 --- affected

People

(Reporter: xidorn, Assigned: xidorn)

References

(Depends on 1 open bug)

Details

NS_ReleaseOnMainThread should take already_AddRefed instead of smart pointers to reduce risks like what I mentioned in bug 1210747.
See Also: → 1210747
Summary: NS_ReleaseOnMainThread should take already_AddRefed instead of smart pointers → NS_ReleaseOnMainThread and NS_ProxyRelease should take already_AddRefed instead of smart pointers
This change would also benefit from static analysis on Move semantics I proposed in bug 1186706.
I want to use the LeakPtr class I created in bug 1186745.
Assignee: nobody → quanxunzhen
Depends on: 1186745
Depends on: 1217308
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1164581
You need to log in before you can comment on or make changes to this bug.