Closed Bug 1210822 Opened 4 years ago Closed 4 years ago

Remove larch graphene builds

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kgrandon, Assigned: aselagea)

References

Details

Attachments

(2 files)

In bug 1130090 we added builds for graphene on larch. The graphene support is now merged to mozilla-central. We want to keep the code to run graphene builds on mozilla-central, but no longer need builds running on larch.

I believe this just needs buildbot changes?
Hi Chris,

You helped us add horizon larch builds in bug 1160717. Now that this code is on mozilla-central, I was wondering if you could help us turn these larch builds off, or forward the request to the appropriate person. 

We do want to enable horizon/browser.html builds on mozilla-central in the future, I'm not sure if it's easier for that to be a separate bug though.

Thank you!
Flags: needinfo?(coop)
There's also a balrog setup for updates that can be removed.
(In reply to Kevin Grandon :kgrandon from comment #1)
> Hi Chris,
> 
> You helped us add horizon larch builds in bug 1160717. Now that this code is
> on mozilla-central, I was wondering if you could help us turn these larch
> builds off, or forward the request to the appropriate person. 
> 
> We do want to enable horizon/browser.html builds on mozilla-central in the
> future, I'm not sure if it's easier for that to be a separate bug though.
> 
> Thank you!

I'm going to try to hand this off to the buildduty contractors, but either way, we can deal with it this week.
Flags: needinfo?(coop)
Alin, try looking at 

http://hg.mozilla.org/build/buildbot-configs/file/6b8028f5a2bf/mozilla/b2g_project_branches.py#l155
try removing the graphene definitions here and comparing the builders before and after
Assignee: nobody → alin.selagea
Alin, I think the problem is that the master you set up is a test master, not a build master.  Thus the build jobs do not show up (your existing master is here)

You need to setup a build master.  If you're using create-staging-master.pl, you need to specify -master-kind=build, not test

https://wiki.mozilla.org/ReleaseEngineering/How_To/Setup_Personal_Development_Master#Create_a_build_master

Here is an example of a production master with these builder jobs

http://buildbot-master84.bb.releng.scl3.mozilla.com:8001/builders

(example graphene_larch_linux64 build)
Made some tests on my build master, the conclusion that I could reach is that simply removing graphene&horizon definitions from buildbot-configs/mozilla/b2g_project_branches.py is enough to stop generating larch builders.
Attachment #8672574 - Flags: review?(kmoir)
Comment on attachment 8672574 [details] [diff] [review]
disable_graphene_and_horizon_on_larch.patch

I'm a bit confused why the horizon builds are being removed when the bug states that only graphene builders should be removed. Also, could you please provide a builder diff, thanks!
Sorry, please also remove horizon building from larch for now. We'll reintroduce both of these at a later date on m-c. Thank you!
horizon is graphene with a different branding, so it's fine to remove both.
Attached file builder_diff.txt
Attached builder diff. I limited the builders generated on my master to larch only. There were no builders generated after applying the above patch.
Attachment #8672574 - Flags: review?(kmoir) → review+
Attachment #8672574 - Flags: checked-in+
in production
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.