Closed Bug 1210853 Opened 9 years ago Closed 8 years ago

Animation stutter on "Inbox by GMail" page

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
platform-rel --- -

People

(Reporter: vladan, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [content perf][gfx-noted] [platform-rel-Google] [platform-rel-Gmail])

Attachments

(2 files)

Attached file about:support.txt
STR:

0. Use a Nightly with APZ, on Windows
1. Load https://www.google.com/inbox/?utm_campaign=en&utm_source=inboxzero&utm_medium=promo
2. Wait for the page to finish loading
3. Scroll down the page with the mousewheel

Notice the animation stutter while the "Bundles" and "Reminders" images scroll up the page:
https://www.google.com/inbox/assets/images/bundles/bundles-header.jpg
https://www.google.com/inbox/assets/images/reminders/reminders-header.jpg

There is some less noticeable stutter even without APZ

Tested on: Nightly 44 on Windows 8.1, on an HP i3 (content-perf laptop), about:support attached
Attached file about.support.txt
Same or even worse with Firefox 41.0.1 on openSUSE 13.2 (using both official binaries from mozilla.org or latest from openSUSE OBS)

0. Use Firefox 41.0.1
1. Go to https://inbox.google.com/?pli=1
2. The page partially loads and then Firefox freezes completely. There is a scrolling progress bar wheel at the bottom left corner. 

about:support attached above.

This started happening right after the update to 41.0.1
Forgot to mention that the issue is reproducible in safe mode too.
Vladan, does this still reproduce?
Flags: needinfo?(vladan.bugzilla)
Whiteboard: [content perf] → [content perf][gfx-noted]
Whiteboard: [content perf][gfx-noted] → [content perf][gfx-noted] [platform-rel-Google] [platform-rel-Gmail]
platform-rel: --- → ?
Anthony, can you reproduce on Windows?
Flags: needinfo?(vladan.bugzilla) → needinfo?(anthony.s.hughes)
(In reply to Milan Sreckovic [:milan] from comment #5)
> Anthony, can you reproduce on Windows?

No, I cannot reproduce it on *any* platform with either the latest Firefox builds nor the Nightly this was originally reported against. I suppose this could be device specific, or maybe Google fixed this on their end but not being able to replicate the issue originally means I can't say for certain.

I think we really need Vladan to check this.
Flags: needinfo?(anthony.s.hughes)
platform-rel: ? → -
Milan we looked at this during today's partner triage. We thought WORKSFORME but up to you.
Flags: needinfo?(milan)
Vadym, you were able to reproduce this, do you still see the problem in the latest nightly?  If you do, please reopen the bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(milan) → needinfo?(vkrevs)
Resolution: --- → WORKSFORME
Not on opensuse 42.1 leap and latest firefox from opensuse build service.
Flags: needinfo?(vkrevs)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: