Cold Launch time regression from 2.2 release for Gallery app

RESOLVED DUPLICATE of bug 1211393

Status

Firefox OS
Gaia::Gallery
P2
normal
RESOLVED DUPLICATE of bug 1211393
2 years ago
2 years ago

People

(Reporter: hema, Assigned: pdahiya)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Gallery v2.2 cold launch: 1113ms
Gallery current cold launch: 1207ms (~90ms regression)
Gallery v2.2 USS: 17.71MB
Gallery current USS: 18.98MB (~1.25MB regression)
(Reporter)

Updated

2 years ago
Priority: -- → P2
(Assignee)

Updated

2 years ago
Assignee: nobody → pdahiya
(Assignee)

Comment 1

2 years ago
On raptor I am seeing improved numbers with gecko regression fix, most recent cold launch time is 1.181 s for build posted on 2015-10-02 07:45. 

https://raptor.mozilla.org/dashboard/script/measures?var-device=flame-kk&var-memory=319&var-branch=master&var-test=cold-launch

I will look into how we can improve the launch time further. Thanks!
(Assignee)

Comment 2

2 years ago
Running raptor locally for Flame-kk 319 MB BuildId:20151002030232 for light reference gallery work load

[Cold Launch: gallery.gaiamobile.org] Results from gallery.gaiamobile.org

| Metric                | Mean   | Median | Min    | Max    | StdDev | p95    |
| --------------------- | ------ | ------ | ------ | ------ | ------ | ------ |
| navigationLoaded      | 721    | 721    | 721    | 721    | 0      | 721    |
| navigationInteractive | 723    | 723    | 723    | 723    | 0      | 723    |
| visuallyLoaded        | 1363   | 1363   | 1363   | 1363   | 0      | 1363   |
| contentInteractive    | 1364   | 1364   | 1364   | 1364   | 0      | 1364   |
| mediaEnumerated       | 1905   | 1905   | 1905   | 1905   | 0      | 1905   |
| fullyLoaded           | 21843  | 21843  | 21843  | 21843  | 0      | 21843  |
| pss                   | 13.500 | 13.500 | 13.500 | 13.500 | 0      | 13.500 |
| uss                   | 10.400 | 10.400 | 10.400 | 10.400 | 0      | 10.400 |
| rss                   | 24.200 | 24.200 | 24.200 | 24.200 | 0      | 24.200 |

I am seeing cold launch time higher, but uss numbers doesn't show any regression.
(Assignee)

Comment 3

2 years ago
Resolving this bug as duplicate of Bug 1211393 and track cold launch time and related start up improvements for gallery as part of bug 1211393.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1211393
You need to log in before you can comment on or make changes to this bug.