Joining WLAN secured with WPA2 and 64-Characters (hex) pre-shared key impossible

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
3 years ago
8 months ago

People

(Reporter: Neuromancer2013, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150918100310

Steps to reproduce:

My smartphones and OS versions:
Geeksphone Revolution with FxOS Boot2Gecko 2.2.0.0-prerelease, Build Id 20150213173239
ZTE Open with FxOS Boot2Gecko 2.2.0.0-prerelease, Build ID 20140909021225

Assume joining an access point with WPA2 using 64 characters (hex) pre-shared key!

1, Settings -> turn on Wi-Fi -> Available networks are listed with "Secured with WPA-PSK"
2. Password input only accepts 63 characters, I have to input 64 characters (hex) pre-shared key to avoid the following error message:
"Unable to connect to xxx, authentication failed due to bad credentials.
Please re-enter the network password."
3. Using other WLAN-APs with WPA2 encryption but shorter PSKs works well.


Actual results:

Cannot join access points with WPA2 using 64 characters (hex) pre-shared key with my FxOS smartphones.
Android ones, iOS ones and Symbian ones work.


Expected results:

FirefoxOS accepts besides 8-63 "ASCII" characters as pre-shared keys 64 charcters "HEX" too.

Additional question(s):
Does this bug relate to all other FxOS versions too?
(Reporter)

Updated

3 years ago
Severity: normal → major
(Reporter)

Updated

3 years ago
Hardware: ARM → All

Comment 1

8 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.