Closed Bug 1210930 Opened 4 years ago Closed 4 years ago

"Back" button is not shown in the Private Mode

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: MaxIvanov, Assigned: pelloux)

References

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(3 files)

Description:
"Back" button works but not showed up when user use the browser in the private mode

Repro Steps:
1) Update a Aries to 20151002110616
2) Launch the Browser and open new private window 
3) Navigate any page 
4) Tap on any link

Actual:
"Back" button is not showed

Expected:
"Back" button should be showed next to address bar

Environmental Variables:
Device: Aries Master
Build ID: 20151002110616
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: af01a617cb76f0ced4e33f82a9567bbba44b9f24
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0


Repro frequency: (100%)
See attached: (screenshot)
This issue DOES occur on Aries 2.5 and Flame 2.5 and DOES NOT on Flame 2.2 
Result: "Back" button is not showed

Device: Aries Master
Build ID: 20151002110616
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: af01a617cb76f0ced4e33f82a9567bbba44b9f24
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
--------------------------------------------------------------------

Device: Flame Master Kk Full flash (319mb)
Build ID: 20151002025740
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
-----------------------------------------------------------------------

Device: Flame 2.2 Kk Full flash (319mb)
Build ID: 20151002032503
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 2ab95b3d02a7
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
Attached image 2015-10-02-12-21-47.png
This works for me, using:
Build ID               20151001150204
Gaia Revision          bd8ff00faac97ad6a2df5a6217910b8d295d56a3
Gaia Date              2015-10-01 06:59:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c1fb007137dcb68b1862a79553b53f1a34c99c3
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151001.182807
Firmware Date          Thu Oct  1 18:28:19 EDT 2015
Bootloader             L1TC000118D0
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: jthomas
Blocks 2.5 with P2 priority. Needs to be fixed.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
B2g Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20151001104128
Gaia: c9bd0434942941f09d7b62dee715a87bfdcd811e
Gecko: b0b053cb93e554b0b0dc8060d8aa3e01c993b096
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20151001110326
Gaia: b4faf783aa6ea63eb2393ea15d403bb964cb4085
Gecko: ed833afe16580afa00d165b32aeacc83da3587e8
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue 
Gaia: c9bd0434942941f09d7b62dee715a87bfdcd811e
Gecko: ed833afe16580afa00d165b32aeacc83da3587e8

Last Working gecko / First Broken gaia - This issue DOES occur with broken gaia.
Gecko: b0b053cb93e554b0b0dc8060d8aa3e01c993b096
Gaia: b4faf783aa6ea63eb2393ea15d403bb964cb4085

B2g Inbound Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/c9bd0434942941f09d7b62dee715a87bfdcd811e...b4faf783aa6ea63eb2393ea15d403bb964cb4085

This issue is caused by Bug 1208170
Blocks: 1208170
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: jthomas
Fabien the changes for bug 1208170 seem to have caused this issue.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(fabien)
Duplicate of this bug: 1211800
Flags: needinfo?(fabien)
Assignee: nobody → pierre-eric
Status: NEW → ASSIGNED
Attachment #8670412 - Flags: review?(etienne)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Private Browsing]
Comment on attachment 8670412 [details] [review]
[gaia] Phoxygen:bug1210930-back-button-image-missing > mozilla-b2g:master

redirecting
Attachment #8670412 - Flags: review?(etienne) → review?(apastor)
Comment on attachment 8670412 [details] [review]
[gaia] Phoxygen:bug1210930-back-button-image-missing > mozilla-b2g:master

Is not any of our Gij tests checking this? Would you mind to add a UI test that fails with current master but passes with your patch? r=me with that. Thanks!
Attachment #8670412 - Flags: review?(apastor) → review+
Summary: "Back" button is not showed in the Private Mode → "Back" button is not shown in the Private Mode
PR already created in bug 1213898
(In reply to Reza Akhavan [:jedireza] from comment #12)
> PR already created in bug 1213898

This bug also has the trivial PR attached.
I spent some time last week trying to build the UI test requested by Alberto in comment 11 - hopefully I can update the PR today.
Ah, thanks for clarifying Pierre Eric :) I was reading fast and overlooked that.
Blocks: 1213898
PR updated, with a test for the back button.
I can add a similar one for the forward button but I'd like some feedback on the code first. 
Alberto would you mind taking a look at it?
Flags: needinfo?(apastor)
Hey Pierre! I cannot see the test. Could you please point me to it? Thanks!
Flags: needinfo?(apastor) → needinfo?(pierre-eric)
Duplicate of this bug: 1213898
Sorry, pushed to the wrong repository...
Mistake corrected: you can now see the test in the PR.
Flags: needinfo?(pierre-eric) → needinfo?(apastor)
The test looks great to me! Thanks for adding it :)
Flags: needinfo?(apastor)
Blocks: 1215095
No longer blocks: 1215095
Merged on master: https://github.com/mozilla-b2g/gaia/commit/8ea9029190
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This test is now perma-orange. Can someone look into this urgently? I'll probably have to close gaia until this can be sorted out.
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: "Back" button is shown next to address bar.
See attachment: verified_Aries_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151018150205
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151018.183443
Firmware Date          Sun Oct 18 18:34:55 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151018193102
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151018.185054
Firmware Date          Sun Oct 18 18:51:02 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Private Browsing] → [QAnalyst-Triage+][COM=Private Browsing][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.