Closed Bug 1210955 Opened 4 years ago Closed 4 years ago

Volume progress bar is broken

Categories

(Firefox OS Graveyard :: AudioChannel, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: MaxIvanov, Assigned: pelloux)

References

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(2 files)

Description:
When a user changes the volume they will see that progress bar is not working. But in fact the function works a level of the volume will change

Repro Steps:
1) Update a Aries to 20151002110616
2) Press the volume button few times

Actual:
Progress bar doesn't work 

Expected:
The progress bar should changes according to the volume level

Environmental Variables:
Device: Aries Master
Build ID: 20151002110616
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: af01a617cb76f0ced4e33f82a9567bbba44b9f24
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: (100%)
See attached: (screenshot)
This issue DOES occur on Aries 2.5 and Flame 2.5 and DOES NOT on Flame 2.2 
Result: Progress bar doesn't work 

Device: Aries Master
Build ID: 20151002110616
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: af01a617cb76f0ced4e33f82a9567bbba44b9f24
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
--------------------------------------------------------------------

Device: Flame Master Kk Full flash (319mb)
Build ID: 20151002025740
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
-----------------------------------------------------------------------

Device: Flame 2.2 Kk Full flash (319mb)
Build ID: 20151002032503
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 2ab95b3d02a7
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
Attached image 2015-10-02-13-12-58.png
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue can be fixed by bug1196724.
Blocks 2.5 with a P1.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P1
QA Contact: sleedavid
B2G Inbound Window:

Last Working:
Environmental Variables:
Device: Flame 2.5
BuildID: 20151001110326
Gaia: c9bd0434942941f09d7b62dee715a87bfdcd811e
Gecko: ed833afe16580afa00d165b32aeacc83da3587e8
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken:
Environmental Variables:
Device: Flame 2.5
BuildID: 20151001104128
Gaia: b4faf783aa6ea63eb2393ea15d403bb964cb4085
Gecko: b0b053cb93e554b0b0dc8060d8aa3e01c993b096
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

PushLog: 
https://github.com/mozilla-b2g/gaia/compare/c9bd0434942941f09d7b62dee715a87bfdcd811e...b4faf783aa6ea63eb2393ea15d403bb964cb4085

This issue appears to be caused by changes made in Bug 1208170
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Fabien this issue seems to be another fallout of bug 1208170.  Can you please take a look?
Blocks: 1208170
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(fabien)
Assignee: nobody → pierre-eric
Status: NEW → ASSIGNED
Flags: needinfo?(fabien)
Attachment #8670765 - Flags: review?(etienne)
Duplicate of this bug: 1209836
Comment on attachment 8670765 [details] [review]
[gaia] Phoxygen:bug1210955-fix-volume-bar-display > mozilla-b2g:master

Much better :)
Thanks! And good call on adding the comment.
Attachment #8670765 - Flags: review?(etienne) → review+
Merged on master: https://github.com/mozilla-b2g/gaia/commit/f82481c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This issue is verified on the latest Aries and Flame 2.5 builds. The volume progress bar works as expected.

Device: Aries Master
Build ID: 20151009104251
Gaia: 1609aecaba381c14eff95d5084e59280f53b7d8b
Gecko: d01dd42e654b8735d86f9e7c723cc869a3b56798
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
------------------------------------------------------------------------

Device: Flame Master
Build ID: 20151009030234
Gaia: 1609aecaba381c14eff95d5084e59280f53b7d8b
Gecko: d01dd42e654b8735d86f9e7c723cc869a3b56798
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
According to comment 12, So I change the Status
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker)
Blocks: 1215095
No longer blocks: 1215095
You need to log in before you can comment on or make changes to this bug.