Closed Bug 1210967 Opened 6 years ago Closed 6 years ago

Talos runs for e10s tests with mozharness: --spsProfile should include profile of content-main thread

Categories

(Testing :: Talos, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1193838

People

(Reporter: kats, Unassigned)

Details

I did a try push at https://treeherder.mozilla.org/#/jobs?repo=try&revision=edd2cc9bfd30&group_state=expanded to get profile information on talos jobs that regressed recently. The profile (e.g. for the TART test under the "s" job) fails to load completely (for which I filed bug 1210964). However, the thread activity panes at the top do load - but unfortunately it only has activity for the "GeckoMain" and "Compositor" threads.

In e10s tests most of the interesting stuff happens in the content process main thread, so that should also be included in these profiles by default.
What changes need to happen for this?  I am unfamiliar with the spsProfiling code to know what to do.
Mike Conley was looking into this recently. As far as I know, there is at least one test for which the profiles contain both the parent and the content process. Mike, do you know what tests already support this, and what's necessary to fix the others?
Flags: needinfo?(mconley)
It's true! I was doing this in bug 1193838, which I had to unfortunately deprioritize this quarter to work on other things. Hoping to get to it again soon.

kats - I have a series of patches in that bug which might work for you for your case.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1193838
No longer blocks: 1210376
You need to log in before you can comment on or make changes to this bug.