MathML appears to have the line-height set too large

RESOLVED DUPLICATE of bug 1208776

Status

()

Core
MathML
RESOLVED DUPLICATE of bug 1208776
2 years ago
2 years ago

People

(Reporter: George Bateman, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8669308 [details]
Screenshot from 2015-10-03 12-09-04.png

On Wikipedia and MDN, MathML takes up way too much vertical space, and matrices are similarly over-spaced. This has been going on for a little while.
On my machine, the Inspector shows:

line-height     > 93px
math > normal   mathml.css:16

at https://developer.mozilla.org/en-US/docs/Mozilla/MathML_Project/MathML_Torture_Test and 

line-height: 71px;
body > 1.5      mdn-min.css:1;
math > normal   mathml.css:16;

at https://developer.mozilla.org/en-US/docs/Web/SVG/Attribute/transform#Types_of_transform_definition.

Updated

2 years ago
Component: General → MathML
Product: Firefox → Core
This is probably a duplicate of bug 1208776. STIX Math as well as some old OpenType MATH fonts do not set the USE_TYPO_METRICS flag, so they no longer work after bug 1170782. You must to upgrade your OpenType MATH to the latest version.
(Reporter)

Comment 2

2 years ago
Thanks Frédéric; upgrading the font does fix the problem. Marking duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208776
You need to log in before you can comment on or make changes to this bug.