Status

Firefox OS
Gaia::System
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
It's no longer needed.
Created attachment 8669310 [details] [review]
[gaia] KevinGrandon:bug_1211134_remove_browser_migrator > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8669310 [details] [review]
[gaia] KevinGrandon:bug_1211134_remove_browser_migrator > mozilla-b2g:master

We no longer need the bookmark migration as we only support upgrading to two versions at a time. Keeping AppMigrator for now though as it will help with home screen migration in the future.

Chris - since you've seen this code lately, or Kyle since you wrote this, wondering if either one of you could take a look. Thanks!
Attachment #8669310 - Flags: review?(kyle)
Attachment #8669310 - Flags: review?(chrislord.net)

Comment 3

3 years ago
Comment on attachment 8669310 [details] [review]
[gaia] KevinGrandon:bug_1211134_remove_browser_migrator > mozilla-b2g:master

This removal looks fine to me, but I really don't know enough about what it's doing/was intended for. If you're confident, I don't mind if you treat this as an r+, but otherwise might be worth waiting for Kyle.
Attachment #8669310 - Flags: review?(chrislord.net)
Comment on attachment 8669310 [details] [review]
[gaia] KevinGrandon:bug_1211134_remove_browser_migrator > mozilla-b2g:master

Burn it all down.
Attachment #8669310 - Flags: review?(kyle) → review+
(Assignee)

Comment 5

3 years ago
Thanks for the reviews!

In master: https://github.com/mozilla-b2g/gaia/commit/b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.