xpti can crash if param type is not resolvable

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: jband_mozilla, Assigned: jband_mozilla)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
I made a bad assumption in xptiInterfaceEntry::GetEntryForParam that all params
that are interfaces types will be resolvable at runtime. I found that on some
interfaces this hit the assert in that code. Big suprise... People declare
params using types that are forward declared but never actually fully declared
in idl. This is perfectly legal. xpti clients should get a error result rather
than a crash. patch coming up.
(Assignee)

Comment 1

17 years ago
Created attachment 65902 [details] [diff] [review]
proposed fix

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 2

17 years ago
Comment on attachment 65902 [details] [diff] [review]
proposed fix

r=dbradley
Attachment #65902 - Flags: review+
(Assignee)

Comment 3

17 years ago
*** Bug 122463 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Marking Verified -
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: xpidl → XPCOM
QA Contact: pschwartau → xpcom
You need to log in before you can comment on or make changes to this bug.