Intermittent browser_ruleview_user-agent-styles.js | This test exceeded the timeout threshold. It should be rewritten or split up

RESOLVED FIXED in Firefox 45

Status

RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: philor, Assigned: tromey)

Tracking

({intermittent-failure})

Trunk
Firefox 46
intermittent-failure

Firefox Tracking Flags

(firefox44 wontfix, firefox45 fixed, firefox46 fixed)

Details

Attachments

(1 attachment)

5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* try: 1
* mozilla-central: 1

Platform breakdown:
* osx-10-10: 3
* linux64: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2015-11-02&endday=2015-11-08&tree=all
8 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 3
* try: 2
* mozilla-inbound: 2
* b2g-inbound: 1

Platform breakdown:
* linux32: 7
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2015-11-30&endday=2015-12-06&tree=all
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 2
* try: 1
* mozilla-central: 1
* b2g-inbound: 1

Platform breakdown:
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2015-12-07&endday=2015-12-13&tree=all
9 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 5
* fx-team: 2
* mozilla-central: 1
* mozilla-aurora: 1

Platform breakdown:
* linux32: 8
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2015-12-14&endday=2015-12-20&tree=all
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 2
* try: 1
* mozilla-inbound: 1
* b2g-inbound: 1

Platform breakdown:
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2015-12-21&endday=2015-12-27&tree=all
(Assignee)

Updated

3 years ago
Assignee: nobody → ttromey
Status: NEW → ASSIGNED
(Assignee)

Comment 6

3 years ago
Created attachment 8702336 [details] [diff] [review]
request longer timeout in browser_ruleview_user-agent-styles.js

This just seems to be a slow test.  The try logs show the test
finishing, then the test harness complaining about exceeding the
timeout.

So, this patch just requests a longer timeout.
(Assignee)

Comment 8

3 years ago
Comment on attachment 8702336 [details] [diff] [review]
request longer timeout in browser_ruleview_user-agent-styles.js

The try run seemed reasonable to me.
Attachment #8702336 - Flags: review?(pbrosset)
16 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* fx-team: 6
* mozilla-inbound: 3
* mozilla-central: 3
* try: 2
* mozilla-aurora: 1
* b2g-inbound: 1

Platform breakdown:
* linux32: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2015-12-28&endday=2016-01-03&tree=all
Comment on attachment 8702336 [details] [diff] [review]
request longer timeout in browser_ruleview_user-agent-styles.js

Review of attachment 8702336 [details] [diff] [review]:
-----------------------------------------------------------------

A lot of our tests seem to have started failing recently because they take too long to run. That's because test machines are sometimes under heavy load, and it's very unfortunate because sometimes there's just no way you can split the test in 2 smaller tests, which is what I would have suggested you did otherwise, but it doesn't make sense for this test.
The tests sometimes run so slowly that there can literally be seconds before an event is emitted as the result of changing something in the UI. Also a lot of our tests are async, going to the server to get data etc. I wish we had more xpcshell unit tests to replace some of the longer ones, but we don't.
So, anyway, I'm ok to simply increase the timeout for this test.
Attachment #8702336 - Flags: review?(pbrosset) → review+

Comment 12

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ed866278df39
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 3
* b2g-inbound: 3
* try: 2
* fx-team: 2

Platform breakdown:
* linux32: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1211224&startday=2016-01-04&endday=2016-01-10&tree=all
status-firefox44: affected → wontfix
status-firefox45: --- → affected
Whiteboard: [checkin-needed-beta]

Comment 14

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/192603a9319a
status-firefox45: affected → fixed

Updated

3 years ago
Whiteboard: [checkin-needed-beta]
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1237529

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.