Remove hover state from selected category item

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: ntim, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Comment 1

2 years ago
Looks like this was intentionally added in bug 591753.
Markus, I don't agree this is useful, clicking on the selected item doesn't do anything, therefor, hover feedback isn't useful either. Usually, when you get hover feedback, you usually expect something to happen when clicking. Also, it makes things inconsistent with the in-content prefs.

Should we keep it ?
Flags: needinfo?(mjaritz)
(In reply to Tim Nguyen [:ntim] from comment #1)
> Looks like this was intentionally added in bug 591753.
> Markus, I don't agree this is useful, clicking on the selected item doesn't
> do anything, therefor, hover feedback isn't useful either. Usually, when you
> get hover feedback, you usually expect something to happen when clicking.
> Also, it makes things inconsistent with the in-content prefs.

Clicking on the selected item takes you back to that category if you have clicked through for more details on an add-on.
(Reporter)

Comment 3

2 years ago
(In reply to Dave Townsend [:mossop] from comment #2)
> (In reply to Tim Nguyen [:ntim] from comment #1)
> > Looks like this was intentionally added in bug 591753.
> > Markus, I don't agree this is useful, clicking on the selected item doesn't
> > do anything, therefor, hover feedback isn't useful either. Usually, when you
> > get hover feedback, you usually expect something to happen when clicking.
> > Also, it makes things inconsistent with the in-content prefs.
> 
> Clicking on the selected item takes you back to that category if you have
> clicked through for more details on an add-on.

That should be made more obvious then (maybe the category icon could be changed into a back icon), and the hover state should only appear in that specific case too.
(In reply to Tim Nguyen [:ntim] from comment #3)
> That should be made more obvious then (maybe the category icon could be
> changed into a back icon), and the hover state should only appear in that
> specific case too.

I agree, the current state is not perfect. My goal when considering this was to minimize the dev effort because I assume we will re-design about:addons more thoroughly in the near future. Looking at it again, I have to agree that this is not obvious enough to be of much help.
If we do a re-design, or want to put more effort into it now, we should put the add-on details in a modal dialog as we do for detailed content in about:preferences (see "Saved Logins…" for example). Which will make leaving details way more obvious.
Ryan made a mock-up for such a screen: https://www.dropbox.com/s/4qks6hfttsspii5/add-ons-modal.png?dl=0 (but this would probably included separating details and options)

Work on an idea for a new add-on manger started (https://bugzilla.mozilla.org/show_bug.cgi?id=1175262) but was halted as we had more pressing issues with add-ons at hand.
Flags: needinfo?(mjaritz)
This is basically working as intended for now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.