Firefox application menu stops working on Mac OS 10.11, breaking quit, preferences, About Firefox, Hide Firefox, etc., including their shortcuts

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: lyarrington, Unassigned, NeedInfo)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8669466 [details]
firefox_2015-10-04-121505_Landons-MacBook-Pro.cpu_resource.diag

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

Relaunching FF several times with a clean install of Mac OS 10.11 El Capitan.


Actual results:

Three related (?) issues: 1) FF does not quit by hitting CMD+q or by selecting Firefox -> Quit Firefox. This happens regardless of whether there are active, open windows. I must force quit FF to have it quit, which logs an unexpected error on Console.

2) FF does not show "About Firefox" from menu when selected. Again, this is regardless of whether there are active, open windows or tabs. I must force quit and re-launch FF to check About Firefox to look for updates. So, it appears that About Firefox only works on first launch.

3) Clicking the FF icon in the dock does not automatically open a new tab or window. CMD+n does, however, open a new tab.


Expected results:

FF should quit as expected with the key combination in the new Mac OS 10.11. The menu options should also work. FF should not have to be manually force-quit.

Comment 1

3 years ago
Err, so obviously something is pretty wrong here...

Firefox does normally respond to cmd-q - at the point where you're doing this, is Firefox otherwise hung and/or not responding to user input? How long are you waiting for the process to die after cmd-q ?

You said this was a newly installed 10.11 install - does this mean the Firefox profile is clean, or did you set up sync or in some other way put data into that profile before this behaviour started showing up? If so, can you try a new, clean profile ( https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles ) ?

Clicking the icon isn't supposed to open a new window/tab. There's a context menu on the icon that lets you open a new window or a new private window. Does that not work, either?



Markus, is there any info you can distill from the resource diagnostics file? Any other approaches you can suggest to get data about what's going on here?
Group: firefox-core-security
Flags: needinfo?(mstange)
Flags: needinfo?(lyarrington)
Created attachment 8670141 [details]
firefox_2015-10-04-121505_Landons-MacBook-Pro.cpu_resource.diag, symbolicated
Attachment #8669466 - Attachment is obsolete: true
(In reply to lyarrington from comment #0)
> 2) FF does not show "About Firefox" from menu when selected. Again, this is
> regardless of whether there are active, open windows or tabs. I must force
> quit and re-launch FF to check About Firefox to look for updates. So, it
> appears that About Firefox only works on first launch.

This sounds like bug 1151345, but that should have been fixed in Firefox 41...

> 3) Clicking the FF icon in the dock does not automatically open a new tab or
> window. CMD+n does, however, open a new tab.

It's only supposed to open a new window if no Firefox windows are currently open.

If you right click on the Dock icon and choose Quit, does that cause Firefox to quit?

I don't see anything in the resource diagnostics file that points to a problem. Can get a process sample from Activity Monitor instead? (Select the Firefox process, click the gear button and choose "Sample Process".)
Flags: needinfo?(mstange)
(Reporter)

Comment 4

3 years ago
Created attachment 8670479 [details]
Sample of Firefox.txt is recommended Activity Monitor sample after having closed all windows/tabs and attempting to CMD+q three times in a row with no effect.
Flags: needinfo?(lyarrington)
(Reporter)

Comment 5

3 years ago
Created attachment 8670482 [details]
Sample of Firefox2.txt is a 2nd sample from recommended Activity Monitor sampling w/ all windows/tabs closed, but this time clicking FireFox->About FF, also with no effect
(Reporter)

Comment 6

3 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> Firefox does normally respond to cmd-q - at the point where you're doing
> this, is Firefox otherwise hung and/or not responding to user input? How
> long are you waiting for the process to die after cmd-q ?
No hangs of any sort, and successful exiting from all windows/tabs by either keyboard or mouse/trackpad options. So far, I have not gotten FF to successfully quit and have had to force quit it under these conditions.
> You said this was a newly installed 10.11 install - does this mean the
> Firefox profile is clean, or did you set up sync or in some other way put
> data into that profile before this behaviour started showing up? If so, can
> you try a new, clean profile (
> https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> profiles ) ?
I do not use FF sync, not since ~2011, so I did not even look around or access these features. I wanted to see what FF would do on a completely fresh 10.11 install, and these effects were noticeable from the start. Also, I did not allow FF to import settings from Safari. I did, however, import bookmarks via .html file several hours after having installed FF.
> Clicking the icon isn't supposed to open a new window/tab. There's a context
> menu on the icon that lets you open a new window or a new private window.
> Does that not work, either?
Clicking and holding trackpad on the dock icon does show both options. I tried closing all windows/tabs just now and clicking dock icon to see whether FF would open new window, and it did this. I know this feature is supposed to occur only when FF has no open windows/tabs. This isn't regular though. But since I can't recreate the behavior right now, could possibly shelf this issue.
(Reporter)

Comment 7

3 years ago
(In reply to lyarrington from comment #6)
> No hangs of any sort, and successful exiting from all windows/tabs by either
> keyboard or mouse/trackpad options. So far, I have not gotten FF to
> successfully quit and have had to force quit it under these conditions.
in fact, while typing this comment i have tried CMD+q several times, and again, no effect. I just now also selected Ff->Quit Ff, and nothing. Interestingly, the CMD+q option highlight-selects the top menu Firefox option twice, as if it were double-clicked.
(Reporter)

Comment 8

3 years ago
(In reply to lyarrington from comment #7)
> (In reply to lyarrington from comment #6)
> > No hangs of any sort, and successful exiting from all windows/tabs by either
> > keyboard or mouse/trackpad options. So far, I have not gotten FF to
> > successfully quit and have had to force quit it under these conditions.
> in fact, while typing this comment i have tried CMD+q several times, and
> again, no effect. I just now also selected Ff->Quit Ff, and nothing.
> Interestingly, the CMD+q option highlight-selects the top menu Firefox
> option twice, as if it were double-clicked.

Oh oh! Holding a left-click via trackpad on the FF dock icon and selecting Quit made FF quit normally. This occurred without any open windows/tabs.

Comment 9

3 years ago
For what it's worth, I'm also seeing this (on OS X 10.9.5). It seems to happen sporadically, and I can't figure out exactly when and when it doesn't happen, but Firefox won't respond to Cmd-Q or to quitting from the Firefox menu. Quitting from the Dock (as lyarrington says above) does cause it to quit normally.

Comment 10

3 years ago
(In reply to michael from comment #9)
> For what it's worth, I'm also seeing this (on OS X 10.9.5). It seems to
> happen sporadically, and I can't figure out exactly when and when it doesn't
> happen, but Firefox won't respond to Cmd-Q or to quitting from the Firefox
> menu. Quitting from the Dock (as lyarrington says above) does cause it to
> quit normally.

If you open the browser console (cmd-shift-j) after Firefox refuses to quit using the menu, are there errors in there (ideally ones that appear a second time if you try again and it fails to quit again) ?

Comment 11

3 years ago
(In reply to :Gijs Kruitbosch from comment #10)

> If you open the browser console (cmd-shift-j) after Firefox refuses to quit
> using the menu, are there errors in there (ideally ones that appear a second
> time if you try again and it fails to quit again) ?

Sadly, no. Nothing in the system console either. It seems to happen more often when the browser has been open for longer. If I open up Firefox and try to quit immediately it works. I wish I could be of more help.

Comment 12

3 years ago
I've this problem too with FF 41 and El Capitan.

A few observations from my side:

- You have to use FF for a whik

Comment 13

3 years ago
I've this problem too with FF 41 and El Capitan. I have created a new profile to see if it's something profile related. And it's not. A fresh profile has the same problem.

A few observations from my side:

- You have to use FF for a while so that it "ignores" the regular Cmd+q and you have to force quit. A freshly opened FF quits nicely. Also using FF for e.g. 3 minutes with 5 websites still makes it normally quit. But after let's say 20 minutes of regular surfing with quite a few tabs open regular quitting won't work for me.

- When you hit Cmd+Q the "Firefox" in the menu bar flashes shortly.

- I can also confirm the points 2) and 3) in the first post.

Comment 14

3 years ago
If, when stuff is broken, you:

- go to about:config
- enable the "devtools.chrome.enabled" preference (set to true)

after that:
- open the browser console (cmd-shift-j)
- execute:

document.getElementById("cmd_quitApplication").doCommand()


Does that quit Firefox ?

What about:


goQuitApplication()

?

If neither works, what does:

canQuitApplication()


return?

And does:

Services.startup.quit(Components.interfaces.nsIAppStartup.eAttemptQuit);

work?

If none of that works:

Services.startup.quit(Components.interfaces.nsIAppStartup.eForceQuit);

does that do the job?

If that doesn't work, it sounds like something in our cocoa widget code is pretty confused... :-\


It would also be useful if someone could verify whether they can reproduce with more recent copies of Firefox (particularly https://beta.mozilla.org/, https://aurora.mozilla.org/, https://nightly.mozilla.org/ -- for the latter two, you should probably turn off e10s to ensure that we've actually fixed whatever it is that's broken here)

Comment 15

3 years ago
I'm also running into this bug randomly on two different Macs.  I found this bug report after closing Firefox by its dock icon, so I can't yet test Gijs' suggestions.  The right-click dock option was "Quit", not "Force Quit".  One Firefox window was open when the bug started, but it persisted even after that last window was manually closed by the red button.

I encountered this bug soon after launching Firefox (less than a minute later), so it wasn't about uptime, in my case.

I found that Firefox also ignores other Menu options like Firefox > About Firefox, while being unable to Quit.  

Affected devices: 

Mid-2007 iMac running OS X 10.11, Firefox Beta 42.0b4  
~2013 MacBook Pro running OS X 10.11, Firefox Release 41.0.1  

Both Firefox Profiles are distinct and not synced.  Both disabled warnings when closing multiple tabs.

Comment 16

3 years ago
(In reply to :Gijs Kruitbosch from comment #14)

> document.getElementById("cmd_quitApplication").doCommand()
> 
> Does that quit Firefox ?

This worked, yes. Can't yet confirm on the others, since it seems like Firefox has to run a while before this bug manifests.

Comment 17

3 years ago
(In reply to michael from comment #16)
> (In reply to :Gijs Kruitbosch from comment #14)
> 
> > document.getElementById("cmd_quitApplication").doCommand()
> > 
> > Does that quit Firefox ?
> 
> This worked, yes. Can't yet confirm on the others, since it seems like
> Firefox has to run a while before this bug manifests.

if this works, I expect the others work, too.

It sounds like somehow menubar input no longer works right when we get into this state. The click/keyboard events aren't actually running the code they're supposed to.

Do any of the items in the "File" menu (or any of the other menus, or the "Preferences" item in the Firefox one) do something at this point?

The other thing that would be interesting is knowing if this happens with Firefox 40 (previous release) or newer builds (see bottom of comment #14), to work out if/when this started breaking, or if it's something new to El Capitan that is somehow causing this.

FWIW, I've still never seen this, but I'm on Yosemite...

Markus, do you have any ideas so far?
Flags: needinfo?(mstange)

Comment 18

3 years ago
(In reply to :Gijs Kruitbosch from comment #17)

> The other thing that would be interesting is knowing if this happens with
> Firefox 40 (previous release) or newer builds (see bottom of comment #14),
> to work out if/when this started breaking, or if it's something new to El
> Capitan that is somehow causing this.

I'm seeing this on 10.9 (Mavericks) on two of my machines. I haven't used my El Capitan laptop much recently so I'm not sure if it's showing up there or not either. I don't recall having run into it before the last week  or so, so it's probably a FF 41 issue.

Comment 19

3 years ago
(In reply to michael from comment #18)
> (In reply to :Gijs Kruitbosch from comment #17)
> 
> > The other thing that would be interesting is knowing if this happens with
> > Firefox 40 (previous release) or newer builds (see bottom of comment #14),
> > to work out if/when this started breaking, or if it's something new to El
> > Capitan that is somehow causing this.
> 
> I'm seeing this on 10.9 (Mavericks) on two of my machines. I haven't used my
> El Capitan laptop much recently so I'm not sure if it's showing up there or
> not either. I don't recall having run into it before the last week  or so,
> so it's probably a FF 41 issue.

OK. That's very odd, because I run beta as my usual build, which was 41 until it got released, and 42 now, and I've never seen this before... If it reproduces on a clean profile it shouldn't be add-on related, but then I'm not sure what's the difference between our machines...

Comment 20

3 years ago
(In reply to :Gijs Kruitbosch from comment #17)

> Do any of the items in the "File" menu (or any of the other menus, or the
> "Preferences" item in the Firefox one) do something at this point?

As for me it's a no. The "settings" and "hide" items don't work either as soon as "quit" has stopped working.

Comment 21

3 years ago
(In reply to Steffen Kupfer from comment #20)
> (In reply to :Gijs Kruitbosch from comment #17)
> 
> > Do any of the items in the "File" menu (or any of the other menus, or the
> > "Preferences" item in the Firefox one) do something at this point?
> 
> As for me it's a no. The "settings" and "hide" items don't work either as
> soon as "quit" has stopped working.

OK, and the other menus? Like opening a new window/tab from the File menu, or Tools > Downloads? Is everything dead at this point?
(Reporter)

Comment 22

3 years ago
(In reply to :Gijs Kruitbosch from comment #14)

> - go to about:config
> - enable the "devtools.chrome.enabled" preference (set to true)
> 
> after that:
> - open the browser console (cmd-shift-j)
> - execute:
> 
> document.getElementById("cmd_quitApplication").doCommand()

Yes, to my surprise, it did work. I tried this right after attempting normal quits, and it succeeded.

> Does that quit Firefox ?
> 
> What about:
> 
> goQuitApplication()
> 
> If neither works, what does:
> 
> canQuitApplication()
> 
> return?
> 
> And does:
> 
> Services.startup.quit(Components.interfaces.nsIAppStartup.eAttemptQuit);
> 
> work?
> 
> If none of that works:
> 
> Services.startup.quit(Components.interfaces.nsIAppStartup.eForceQuit);
> 
> does that do the job?

I can't say that these options also do the trick, because, as michael notes, it definitely is a matter of how long the app has been running.

I was also beginning to wonder whether video or media playback has a hand in this. I do not have Flash installed on this machine at all. The other day I went full-screen on a youtube video embedded in a separate website. About 1m43s into it, the machine suddenly went into my login screen. I had no other apps running at all. I relogged in and tried to restore session, and the sites restored themselves but did so in a very strange looking window--i.e., there was a relatively huge title bar space, the tab sizes were not symmetrical. Opening new windows and then new tabs in that new window returned to normal, expected behavior.

This may be unrelated. But, it made me wonder whether HTML5 playback might have something to do with the time variable?

> It would also be useful if someone could verify whether they can reproduce
> with more recent copies of Firefox (particularly https://beta.mozilla.org/,
> https://aurora.mozilla.org/, https://nightly.mozilla.org/ -- for the latter
> two, you should probably turn off e10s to ensure that we've actually fixed
> whatever it is that's broken here)

I could try this, or try to downgrade to FF 40, per Gjis's suggestion. I admittedly have not tried to re-install FF 41. I'm assuming other folks experiencing the bug have tried fresh re-installs of FF 41?
(Reporter)

Comment 23

3 years ago
(In reply to :Gijs Kruitbosch (PTO oct 9) from comment #14)
> What about:
> 
> goQuitApplication()

yes, i can now say that this does work.

> ?
> 
> If neither works, what does:
> 
> canQuitApplication() 
> return?

this returns "true"
 
> And does:
> 
> Services.startup.quit(Components.interfaces.nsIAppStartup.eAttemptQuit);
> 
> work?

yes, this works

> If none of that works:
> 
> Services.startup.quit(Components.interfaces.nsIAppStartup.eForceQuit);
> 
> does that do the job?

yes, this works too. i tried all these measures yesterday and early this morning after the normal quit procedures ceased.

Comment 24

3 years ago
(In reply to :Gijs Kruitbosch (PTO oct 9) from comment #21)

> OK, and the other menus? Like opening a new window/tab from the File menu,
> or Tools > Downloads? Is everything dead at this point?

Everything works fine except the Firefox menu. Nothing is hanging, but none of the options in the Firefox menu (About, Preferences, Hide, Quit) works, nor do any of their associated keyboard shortcuts.

Comment 25

3 years ago
Confirming per the mass of reports.

(In reply to michael from comment #24)
> (In reply to :Gijs Kruitbosch (PTO oct 9) from comment #21)
> 
> > OK, and the other menus? Like opening a new window/tab from the File menu,
> > or Tools > Downloads? Is everything dead at this point?
> 
> Everything works fine except the Firefox menu. Nothing is hanging, but none
> of the options in the Firefox menu (About, Preferences, Hide, Quit) works,
> nor do any of their associated keyboard shortcuts.

OK. So clearly something is breaking the application menu somehow... Markus is the expert here, but until he chimes in, I'm willing to keep pottering on...

It would be useful to know if a build that included the fix for bug 1181977 (simple thing to test: https://www.mozilla.org/en-US/firefox/developer/ ) would work here. Firefox Developer Edition will automatically use a separate profile from a normal release build, so it shouldn't interfere with your normal Firefox usage (beyond perhaps prompting to be made the default browser).

I also pushed a version of current 41-release with the patch from that bug included to our "try" repository, which means it's building here: 

remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=2d14145737bd

which means builds should ultimately appear here:

https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/gijskruitbosch@gmail.com-2d14145737bd

(which is likely to take at least another 2 hours, potentially 4 hours)

Note about the "try" build: they're built with "unofficial" brandings, so they won't show up as "Firefox" but as "Nightly", but it'll essentially be version 41 off the mozilla-release repository with the patch from bug 1181977 added.
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
Summary: Firefox doesn't quit on Mac OS 10.11, must 'Force Quit' → Firefox application menu stops working on Mac OS 10.11, breaking quit, preferences, About Firefox, Hide Firefox, etc., including their shortcuts

Comment 26

3 years ago
This bug is not OS version dependent.  I'm seeing it on 10.6.8 as well, on the FDE channel with v43.

Pretty much the same experience -- it takes a little while to manifest; quit via the dock icon.  Relaunching restores the menu function.  All the other menus function.

I've also noticed that the "About" dialog glitches graphically, and sometimes doesn't draw the logo fully.
(Reporter)

Comment 27

3 years ago
(In reply to carmudgeon from comment #26)
> This bug is not OS version dependent.  I'm seeing it on 10.6.8 as well, on
> the FDE channel with v43.
> 
> Pretty much the same experience -- it takes a little while to manifest; quit
> via the dock icon.  Relaunching restores the menu function.  All the other
> menus function.
> 
> I've also noticed that the "About" dialog glitches graphically, and
> sometimes doesn't draw the logo fully.

yeeup, and i can confirm all the same behavior and effects on the recent update to 41.0.2.

also, any thoughts on the possible relationship to media playback? i've noticed that sometimes playback will cause a large horizontal black bar across the screen approximately the same width as whatever frame the media was played in. however, for fullscreen applications, the horizontal bar will only take the width of the original media frame and not the whole screen.

can anyone experiencing these quit, about menu effects, etc., corroborate the playback effects?

Comment 28

3 years ago
Just chiming in that I am seeing the issue here - I've deployed the latest stable Firefox on about 50 school Mac computers (OS versions 10.6 to 10.10)

For example, after a class of 30 completed an online test, I was able to test each laptop for the issue. 5 of them did not quit from the application menu/cmd-q. (From memory, 4 were 10.6, the other 10.9).

Clean Firefox profiles, clean cache, no fancy addons, etc.

Comment 29

3 years ago
At this point, does anyone have any idea what's triggering the issue? It would really help if we had deterministic steps to reproduce.

(In reply to lyarrington from comment #27)
> (In reply to carmudgeon from comment #26)
> > This bug is not OS version dependent.  I'm seeing it on 10.6.8 as well, on
> > the FDE channel with v43.
> > 
> > Pretty much the same experience -- it takes a little while to manifest; quit
> > via the dock icon.  Relaunching restores the menu function.  All the other
> > menus function.
> > 
> > I've also noticed that the "About" dialog glitches graphically, and
> > sometimes doesn't draw the logo fully.
> 
> yeeup, and i can confirm all the same behavior and effects on the recent
> update to 41.0.2.
> 
> also, any thoughts on the possible relationship to media playback? i've
> noticed that sometimes playback will cause a large horizontal black bar
> across the screen approximately the same width as whatever frame the media
> was played in. however, for fullscreen applications, the horizontal bar will
> only take the width of the original media frame and not the whole screen.
> 
> can anyone experiencing these quit, about menu effects, etc., corroborate
> the playback effects?

These sound like separate graphics problems to me; it seems unlikely that they would be related. You could file a separate bugreport about them, including the graphics subsection of about:support (Help > Troubleshooting Information).

(In reply to Lee from comment #28)
> Just chiming in that I am seeing the issue here - I've deployed the latest
> stable Firefox on about 50 school Mac computers (OS versions 10.6 to 10.10)
> 
> For example, after a class of 30 completed an online test, I was able to
> test each laptop for the issue. 5 of them did not quit from the application
> menu/cmd-q. (From memory, 4 were 10.6, the other 10.9).

Any other ideas about commonalities between the machines that were / weren't affected in terms of hardware or what steps were/weren't used?

Comment 30

3 years ago
(In reply to :Gijs Kruitbosch from comment #29)
> Any other ideas about commonalities between the machines that were / weren't
> affected in terms of hardware or what steps were/weren't used?

I variety of 2009 MacBooks, 2012 MacBook Pros but affected all.

-----

However, I think I may have found a way to reproduce the issue - just need someone else to confirm:

-Open Firefox fresh
-Open a new tab
-Close Firefox by using the red cross on the far top left
-Launch Firefox again
-Application menu and corresponding keyboard shortcuts no longer function.

I only have access to 1 machine at the moment.

Comment 31

3 years ago
(In reply to Lee from comment #30)
> However, I think I may have found a way to reproduce the issue - just need
> someone else to confirm:
> 
> -Open Firefox fresh
> -Open a new tab

You do nothing with this tab, right?

> -Close Firefox by using the red cross on the far top left

Do you get the "you are closing multiple tabs" prompt?

> -Launch Firefox again

How exactly are you relaunching Firefox? 

> -Application menu and corresponding keyboard shortcuts no longer function.

I couldn't reproduce with these steps, but that could be because I use the profile manager and run many profiles/instances of Firefox, which may muddle the waters. I'll try to reproduce some more, but it would also be good if you could nail down the steps you gave a bit further (maybe you're relaunching from a finder window instead of the dock, or by clicking a link, or...?).
Flags: needinfo?(lee.mason)

Comment 32

3 years ago
(In reply to :Gijs Kruitbosch from comment #31)
> (In reply to Lee from comment #30)
> > However, I think I may have found a way to reproduce the issue - just need
> > someone else to confirm:
> > 
> > -Open Firefox fresh
> > -Open a new tab
> 
> You do nothing with this tab, right?

Correct

> > -Close Firefox by using the red cross on the far top left
> 
> Do you get the "you are closing multiple tabs" prompt?

No

> > -Launch Firefox again
> 
> How exactly are you relaunching Firefox? 

From the dock

> > -Application menu and corresponding keyboard shortcuts no longer function.
> 
I made a new accound on the MacBook, with new profile, can't reproduce. Still investigating.
Flags: needinfo?(lee.mason)

Comment 33

3 years ago
Ok so this might be a weird bug related to the uBlock extension. Try and see if this reproduces the problem:

[Using a new Firefox profile]
-Install the uBlock extension
-Quit and restart Firefox (from the dock)
-Open a new tab and wait at least 5 seconds
-Close Firefox by using the red cross on the far top left
-Relaunch Firefox (from the dock)
-Wait at least 5 seconds
-Application menu and corresponding keyboard shortcuts no longer function.


*When I also install another extension (e.g. Gmail Notifier), this problem cannot be reproduced.

Comment 34

3 years ago
(In reply to Lee from comment #33)
> Ok so this might be a weird bug related to the uBlock extension. Try and see
> if this reproduces the problem:
> 
> [Using a new Firefox profile]
> -Install the uBlock extension
> -Quit and restart Firefox (from the dock)
> -Open a new tab and wait at least 5 seconds
> -Close Firefox by using the red cross on the far top left
> -Relaunch Firefox (from the dock)
> -Wait at least 5 seconds
> -Application menu and corresponding keyboard shortcuts no longer function.
> 
> 
> *When I also install another extension (e.g. Gmail Notifier), this problem
> cannot be reproduced.

I reproduced this once, but haven't been able to reproduce it again, using the same steps (well, on the same profile).

Comment 35

3 years ago
Created attachment 8677201 [details]
About dialog misdrawn

Just to follow up on the drawing glitch I mentioned earlier; this is how it appears.

I was able to capture it while running a nightly in response to a different bug (with a virgin profile), but I've also seen it appear in FDE.

It may very well also appear in the stable releases, but since that dialog is rarely brought up for updates (I manually update and don't use the auto-update mechanism), I can't say with certainty.

Comment 36

3 years ago
(In reply to Lee from comment #33)
> Ok so this might be a weird bug related to the uBlock extension. Try and see
> if this reproduces the problem:
> 
> [Using a new Firefox profile]
> -Install the uBlock extension
> -Quit and restart Firefox (from the dock)
> -Open a new tab and wait at least 5 seconds
> -Close Firefox by using the red cross on the far top left
> -Relaunch Firefox (from the dock)
> -Wait at least 5 seconds
> -Application menu and corresponding keyboard shortcuts no longer function.
> 
> 
> *When I also install another extension (e.g. Gmail Notifier), this problem
> cannot be reproduced.

There's an issue over on the uBlock Origin issue tracker about this: https://github.com/gorhill/uBlock/issues/737

Comment 37

3 years ago
I can confirm this has happened to me several times. Mac OS X 10.11.1, and FF 41.0.2.  Also have uBLock Origin installed.

After a while the whole FF menu ceases to work.  But the app itself runs fine.  When Quit doesn't work there, it DOES ALWAYS work from the menu on the far right of the toolbar, and hitting the little Power icon to quit, works.

Comment 38

3 years ago
Steps to reproduce:
- start Firefox (42 for me on 10.10)
- close the window (Cmd+W or red X)
- try to open the About box through the main menu

Somehow closing the last window of Firefox disables the main menu.

Comment 39

3 years ago
(In reply to teki from comment #38)
> Steps to reproduce:
> - start Firefox (42 for me on 10.10)
> - close the window (Cmd+W or red X)
> - try to open the About box through the main menu
> 
> Somehow closing the last window of Firefox disables the main menu.

These steps do not reproduce the problem for me on a clean profile.

Comment 40

3 years ago
str
(In reply to :Gijs Kruitbosch from comment #39)
> (In reply to teki from comment #38)
> > Steps to reproduce:
> > - start Firefox (42 for me on 10.10)
> > - close the window (Cmd+W or red X)
> > - try to open the About box through the main menu
> > 
> > Somehow closing the last window of Firefox disables the main menu.
> 
> These steps do not reproduce the problem for me on a clean profile.

Confirmed, only happens when https://addons.mozilla.org/en-US/firefox/addon/ublock/ is installed and active. uBlock Origin is not affected by the problem.
(Reporter)

Comment 41

3 years ago
these bug reports on ublock's github tracker might help shed more light?

https://github.com/gorhill/uBlock/issues/944

and

https://github.com/gorhill/uBlock/issues/737

Comment 42

3 years ago
(In reply to teki from comment #40)
> (In reply to :Gijs Kruitbosch from comment #39)
> > (In reply to teki from comment #38)
> > > Steps to reproduce:
> > > - start Firefox (42 for me on 10.10)
> > > - close the window (Cmd+W or red X)
> > > - try to open the About box through the main menu
> > > 
> > > Somehow closing the last window of Firefox disables the main menu.
> > 
> > These steps do not reproduce the problem for me on a clean profile.
> 
> Confirmed, only happens when
> https://addons.mozilla.org/en-US/firefox/addon/ublock/ is installed and
> active.

Ah. With this I can indeed reproduce on an otherwise clean profile on Firefox 43.

It seems to be fixed on 44 and 45. I'm figuring out what fixed this...

Comment 43

3 years ago
Delightful. This seems to have been fixed by bug 1084009. Why, anyone's guess.

(fix range on inbound: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f7cbf3aa76fc9768bb3c2860226195d1f54e93fc&tochange=ad320eee186e1f57aef89c322148cc3d73c3fc91 )

Kannan / Alex / Chris, any idea what's going on here?

(for STR, see comment #40)
Depends on: 1084009
Flags: needinfo?(mstange)
Flags: needinfo?(kvijayan)
Flags: needinfo?(chris)
Flags: needinfo?(bugzilla)
No idea how my changes affect this problem.  I suspect the underlying problem still exists, and hinges on javascript execution timings.

My patch will affect the execution start time and end time of js scripts (it pushes script compilation to a background thread).

This issue is likely still present, and might show up intermittently still.
Flags: needinfo?(kvijayan)
This works for me with latest Nightly.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Flags: needinfo?(bugzilla)
You need to log in before you can comment on or make changes to this bug.