Regression: IMAP:Mark|As Unread does not get saved in the database

VERIFIED FIXED

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: fenella, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Linux, Mac (1999-08-16-08 M9), Win32 (1999-08-16-09 M9)
Bug 8395 was written to address this problem dated 6/17/99 and it  was marked as
a dup of bug#7513, which has been marked as Verified/Fixed. To avoid the
confusion, I am writing this as a new Regression bug.  If this is a problem,
please let me know.

1. Open Messenger from Task menu
2. Select a "read" message from the IMAP inbox folder
3. Select Message|Mark|As Unread, the selected message turns to "unread" status
4. Exit apprunner and relaunch apprunner mail
5. Notice that message that was marked "unread" did not stay.
Actual result: The status does not show "unread"
Expected result:  The status show show "Unread"
This occurs to all three platforms.

Updated

19 years ago
Assignee: phil → bienvenu

Comment 1

19 years ago
Reassign to bienvenu
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
this is not a regression. What can happen is that the database doesn't get
commited immediately, but the flag change is getting written to the imap server,
and to the database. It will not show up in the UI because of a bug in the tree
control, however.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
although the bug as written isn't really true, I've added a commit immediately
after his operation to force a flush of the db state.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
Linux (1999-09-09-09 M11)
Win_nt 4.0 (1999-09-09-09 M10)
Mac (1999-09-09-08 M11)

I check everything:
IMAP/POP/News: Message|Mark AS Unread works and got saved in the database.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.