Closed Bug 1211306 Opened 4 years ago Closed 4 years ago

Replace a use of deprecated GetVersionEx() with its MFBT equivalent

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: njn, Assigned: njn)

References

Details

Attachments

(1 file, 1 obsolete file)

GetVersionEx() has been deprecated for a while. Instead of just ignoring the
resulting warning, we can use a similar function from MFBT.
Here's a version with the correct condition.
Attachment #8669508 - Flags: review?(jduell.mcbugs)
Attachment #8669483 - Attachment is obsolete: true
Attachment #8669483 - Flags: review?(jduell.mcbugs)
Attachment #8669508 - Flags: review?(jduell.mcbugs) → review+
https://hg.mozilla.org/mozilla-central/rev/a8e67d912ab6
https://hg.mozilla.org/mozilla-central/rev/c87ce743e34e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Duplicate of this bug: 1186475
You need to log in before you can comment on or make changes to this bug.