Closed Bug 1211382 Opened 9 years ago Closed 9 years ago

about:newtab should appear in tab history (e.g. Back button should go to New Tab Page)

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 776167
Tracking Status
firefox44 --- affected

People

(Reporter: djc, Unassigned)

Details

(Keywords: ux-consistency, ux-error-recovery, ux-trust)

I frequently use the about:newtab tiles to go to some of my most-visited sites. If I just want to take a quick look at one of them, then go and visit another one, my muscle memory sometimes tries to go back, but then finds the Back button disabled. It would be more natural/less surprising if about:newtab appeared at the root of the tab history, instead of being outside the normal flow.
Per bug 724239 and bug 1178781, I'm pretty sure this is intentional. I would agree though that the more useful we make this page (and it didn't use to be particularly useful) the more likely people are going to be wanting to go back to it... Philipp/Ed, thoughts about whether we want to reconsider?
Flags: needinfo?(philipp)
Flags: needinfo?(edilee)
Yeah, agreed that it is intentional, but personally I think it makes sense to at least reconsider that decision.
I remember raising this as well and I recall that the reason we didn't do it were of a technical nature.

If we can fix this, we should. From a user perspective there really is no good reason why I can't resolve a mis-click on a tile the same way I can resolve any other mis-click (to name just one scenario).
Flags: needinfo?(philipp)
We can't do this securely until about:newtab no longer has chrome privileges.
Flags: needinfo?(edilee)
Bug 776167 is a straight dupe, and is blocked by bug 776477 which is about unprivileging, so I'm going to dupe this there.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.