Closed Bug 121146 Opened 18 years ago Closed 18 years ago

Collaborate with Spamcop?

Categories

(MailNews Core :: Filters, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 112315

People

(Reporter: dr, Assigned: naving)

References

Details

Something I've been doing religiously recently is forwarding all the spam I get
to spamcop.net. It might be an interesting exercise to more tightly integrate
Mozilla MailNews with Spamcop's service.

I'm envisioning sort of a two-part thing, where you could:

  1. Download predefined spam filters from Spamcop to use in MailNews. Better
     still, have the filters automatically downloaded and updated for you.
  2. Any spam you get is reported as such back to Spamcop, which relays the abuse
     information to the appropriate network maintainers.

This would easily automate things for people who would otherwise be too lazy to
report spam. There could be some very simple UI in Mozilla to mark or unmark
mail as spam (both to avoid false positives and to report unfiltered spam), and
that would be all a user would have to see.

It should go without saying, but the more people who report spam, the less spam
we'll all get. Hmm... maybe I should sell this idea to Yahoo and Hotmail :)
dup of bug 112315?
that's gernerally a very nice idea i'd like to see implemented.
but what happens if some people mistakenly (or even purposefully) report an
"innocent" adress as spam? is spamcop taking that into account? sth like "need
at least 20 reports from different email adresses & ip's to verify someone as spam"

oh, another thing : what happens if all mozilla developers report
bill@microsoft.com as spam? ;->

phil
May I suggest a more dynamic alternative?  SpamNet is a free software friendly
commercial spam tool from CloudMark (http://www.cloudmark.com/)that operates
dynamically in Napster fashion to quickly identify and block spam.  It currently
is being distributed for MS Outlook with an Outlook Express product on the way.
 It would be great to have a Mozilla Mail interface.  It is rather ingenius. 
When a user receives an email he identifies as spam, he simply codes it as spam
back to the spamnet server.  From this point on it will automatically be coded
as spam for all other spamnet participants.  All participants are able to review
spamnet performance and 'vote' to unblock certain mailings that they deem to be
'not spam'.  If a particular participant is repeatedly abusing the system, they
will eventually be ignored, thus making the system both dynamic and self
correcting.  The author of this software develops under Artistic License via
SourceForge and is thus familiar with the free software community and culture.
*** Bug 156337 has been marked as a duplicate of this bug. ***
*** Bug 156492 has been marked as a duplicate of this bug. ***
Suggestion: not just spamcop , but any site that provides a list of spammers, 
like ordb, etc, something like this in the UI:
[x] Use a blacklist server
  server1;server2;server3....
Blacklist-checking is normally a job for the mailserver, not the mailclient.
That will check the identitity of the host trying to send some email, against a
DNS-based list (bl.spamcop.net for instance).

If you'd like to do it yourself, you would have to check all headers in the
mail. And that's not so easy. Spamcop is very good, because Julian Heighthas
written an extensive framework that is really good at that job. But it would be
really difficult to move that into the mailclient (it's written in Perl). And it
would also be very *slow* ...
This bug is pretty much the same as bug 112315. Reopen if you disagree.

*** This bug has been marked as a duplicate of 112315 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Yeah, good enough.
Status: RESOLVED → VERIFIED
*** Bug 188641 has been marked as a duplicate of this bug. ***
*** Bug 203502 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.