Regression: Unable to remove a bookmark from navigation bar

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: sleroux)

Tracking

({regression, reproducible})

unspecified
Other
iOS
regression, reproducible

Firefox Tracking Flags

(fxios1.1+)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Currently on master (1fcfb95efd3859e78c398ed76390bd60d865f0e2) one is unable to tap the bookmark icon in the navigation bar to remove a bookmark.

The work-around is to swipe to delete a bookmark in our flat listing.

Another work-around is to rotate the device and then back again. The hit will register on the button afterwards.
(Reporter)

Comment 1

2 years ago
Created attachment 8669695 [details]
snapkit-log.log

Possibly related snapkit log
Is this a mirrored (synced) bookmark, or did you bookmark this locally?

The former shouldn't appear to be bookmarked at all. The latter should work as expected.
Flags: needinfo?(aaron.train)
(Reporter)

Comment 3

2 years ago
No syncing involved, no account hookup.
Flags: needinfo?(aaron.train)
I think Steph was looking at this, based on IRC scrollback.
Flags: needinfo?(sleroux)
(Assignee)

Comment 5

2 years ago
I'm able to reproduce this on master now. Whenever I tap on the bookmark button, it spins in place instead of jumping out and is not clickable afterwards. 

I just tried setting translatesAutoresizingMaskIntoConstraints to FALSE for the footerBackground BlurWrapper view and that seemed to get rid of the errors but I'm still seeing the unclickable bookmark problem.
Flags: needinfo?(sleroux)
(Assignee)

Comment 6

2 years ago
I can take this one. I feel like it's something related to the introduction of this BlurWrapper.
(Assignee)

Updated

2 years ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
tracking-fxios: ? → 1.1+
(Assignee)

Comment 7

2 years ago
So it looks like this bug was introduced after the bookmark sync stuff landed:

https://github.com/mozilla/firefox-ios/commit/f5ad0aaea4b3627d9aca95c76a06db1a89d3a9be

What's happening is that the star animates in place but doesn't jump up. However, if you wait for 20 seconds, the star will do the jump and is able to be unbookmarked after that. I ran the profiler but didn't see the CPU spinning or anything during that time so there isn't contention happening on the main thread. :rnewman, is there anything during the bookmark sync that might cause an animation to be delayed like this?
Flags: needinfo?(rnewman)
My suspicion is that some work has jumped to the background thread, like…

https://github.com/mozilla/firefox-ios/commit/f5ad0aaea4b3627d9aca95c76a06db1a89d3a9be#diff-6d1fb0cf203fcd3c299d4ba3f07f21deR1007

Betcha that should be .uponQueue(dispatch_get_main_queue(), …)
Flags: needinfo?(rnewman)
(Assignee)

Comment 9

2 years ago
Created attachment 8669911 [details] [review]
https://github.com/mozilla/firefox-ios/pull/1125
Attachment #8669911 - Flags: review?(rnewman)
Attachment #8669911 - Flags: review?(rnewman) → review+
(Assignee)

Comment 10

2 years ago
Merged
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.