Closed Bug 1211627 Opened 6 years ago Closed 6 years ago

Border-box, 100% height and padding not acting appropriately

Categories

(Core :: Layout, defect)

41 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 930218

People

(Reporter: dusanmilko, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36

Steps to reproduce:

http://jsfiddle.net/zg0u6ebs/1/


Actual results:

Firefox incorrectly sizes the green containers width

Seems to be an issue wth 100% height, border-box and padding.


Expected results:

The container of green should be same width as img, it is not. Compare to safari and firefox.
Looks like the image's intrinsic width calculation doesn't take the box-sizing into account when deciding how tall the image will end up being.

As far as I can tell, this is exactly the scenario described in bug 930218.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930218
You need to log in before you can comment on or make changes to this bug.