Closed Bug 1211663 Opened 4 years ago Closed 4 years ago

Unable to interact with the home screen for approximately 1 second after exiting task manager/card view.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1185553
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: Marty, Assigned: mcav)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(1 file, 2 obsolete files)

Description:
When the user exits the task manager to the home screen, they will be unable to scroll the home screen or select apps for approximately 1 whole second.

This occurs whether or not there are any open apps in the task manager, and regardless if the user taps the home button to dismiss the task manager, or if it automatically closes after exiting the last open app.

This issue does NOT occur if the user simply dismisses an open app by tapping the home button, without going through the task manager.

Repro Steps:
1) Update a Aries to 20151005111147
2) Long press the Home button to bring up the task manager
3) Tap the Home Button to dismiss the task manager.
4) Immediately attempt to scroll the Home Screen and tap an application to launch it.

Actual:
The user is unable to interact with the home screen for approximately 1 whole second after closing the Task Manager

Expected:
The user is able to interact with the home screen immediately after dismissing the Task Manager

Environmental Variables:
Device: Aries 2.5
Build ID: 20151005111147
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: 45f01961ecd0ad9a45067f3e08bfb92539042eeb
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
See attached: Video (URL), Logcat
This issue DOES occur on the Flame 2.5 build.
The user is unable to interact with the home screen for approximately 1 whole second after closing the Task Manager

Environmental Variables:
Device: Flame 2.5
BuildID: 20151005030238
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: b56aeea0c4701677ffda6417183caa60d2a6a4a7
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

This issue does NOT occur on Flame 2.2 builds.
The user is able to interact with the home screen immediately after dismissing the Task Manager

Environmental Variables:
Device: Flame 2.2
BuildID: 20151005032502
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 2ab95b3d02a7
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20151002110339
Gaia: 51b91e4d3e692aeb6e5e7cff877a921300af20b2
Gecko: d77a41837bdecdc8d521dd6fdac5d00a5813c879
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Device: Flame 2.5
BuildID: 20151002121840
Gaia: 258d6da499c384d62b865fccafb6ec208f14b67f
Gecko: 041415e9df0b6d24353e3aa187eed02b27071185
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 51b91e4d3e692aeb6e5e7cff877a921300af20b2
Gecko: 041415e9df0b6d24353e3aa187eed02b27071185

Last Working Gecko First Broken Gaia - repro
Gaia: 258d6da499c384d62b865fccafb6ec208f14b67f
Gecko: d77a41837bdecdc8d521dd6fdac5d00a5813c879

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/51b91e4d3e692aeb6e5e7cff877a921300af20b2...258d6da499c384d62b865fccafb6ec208f14b67f

This issue is caused by changes made in Bug 1209402.
Blocks: 1209402
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Blocks 2.5 with a P2 priority
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Marcus this issue seems to have been caused by the changes for bug 1209402.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(m)
Assignee: nobody → m
Flags: needinfo?(m)
Comment on attachment 8671986 [details] [review]
[gaia] etiennesegonzac:bug-1185553 > mozilla-b2g:master

Wrong bug :)
Attachment #8671986 - Attachment is obsolete: true
Attachment #8671987 - Attachment is obsolete: true
Etienne's patch in bug 1185553 will fix this.
Depends on: 1185553
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185553
You need to log in before you can comment on or make changes to this bug.