Closed Bug 1211861 Opened 5 years ago Closed 5 years ago

Dock Options subdialog too narrow

Categories

(Thunderbird :: Preferences, defect)

x86_64
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 44.0

People

(Reporter: foss, Assigned: Paenglab)

Details

Attachments

(2 files, 1 obsolete file)

No description provided.
STR:

1. Set mail.preferences.inContent to true
2. Navigate to General
3. Click App Icon Options... button

What happens:

The subdialog shows as in the screenshoot attached.

What was expected:

Subdialog shoud show completelly. Even buttons are cut off on the right side.
Summary: Dock Options → Dock Options subdialog too narrow
Attached patch 1211861.patch (obsolete) — Splinter Review
The problem is, this dialog uses for the info text a caption to make it bold. But captions don't wrap.

My patch is using now a description with class bold to make the info bold.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8670910 - Flags: review?(aleth)
Comment on attachment 8670910 [details] [diff] [review]
1211861.patch

Review of attachment 8670910 [details] [diff] [review]:
-----------------------------------------------------------------

Your patch fixed the problem, Richard, although I think "bold" makes the caption stand out too much.
Attachment #8670910 - Flags: feedback+
Forget it. Original caption was also bold. So it is fine right now with your patch. Thank you Richard.
Comment on attachment 8670910 [details] [diff] [review]
1211861.patch

Review of attachment 8670910 [details] [diff] [review]:
-----------------------------------------------------------------

Fixes this particular bug, so r+.

There are still some issues with this dialog, if one wanted to be perfectionist:

* There is a blue box around the close button in the top right. This goes away when you press TAB.

* The spacing between the lines of text looks bad. E.g. the space between the "App icon badge" caption and the next line is less than the intra-line spacing in "You can disable the badge...". Some extra whitespace around the caption (above and below) should fix this.
Attachment #8670910 - Flags: review?(aleth) → review+
Attached patch 1211861.patch v2Splinter Review
(In reply to aleth [:aleth] from comment #6)
> Comment on attachment 8670910 [details] [diff] [review]
> 1211861.patch
> 
> Review of attachment 8670910 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Fixes this particular bug, so r+.
> 
> There are still some issues with this dialog, if one wanted to be
> perfectionist:

No need to be perfectionist, it should only look good. ;)

> * There is a blue box around the close button in the top right. This goes
> away when you press TAB.

I moved the script before the prefpane and here the focus in no more shown. Also for you?

> * The spacing between the lines of text looks bad. E.g. the space between
> the "App icon badge" caption and the next line is less than the intra-line
> spacing in "You can disable the badge...". Some extra whitespace around the
> caption (above and below) should fix this.

I added some spacing, do you like it more?
Attachment #8670910 - Attachment is obsolete: true
Attachment #8670962 - Flags: review?(aleth)
Comment on attachment 8670962 [details] [diff] [review]
1211861.patch v2

Review of attachment 8670962 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Richard Marti (:Paenglab) from comment #7)
> > * There is a blue box around the close button in the top right. This goes
> > away when you press TAB.
> 
> I moved the script before the prefpane and here the focus in no more shown.
> Also for you?

Yes, it's gone now!

However, the real bug here is that the options in the window are not keyboard-accessible (i.e. if you keep pressing TAB you never get to the checkbox etc). That's for a separate bug though (and maybe m-c?).

> > * The spacing between the lines of text looks bad. E.g. the space between
> > the "App icon badge" caption and the next line is less than the intra-line
> > spacing in "You can disable the badge...". Some extra whitespace around the
> > caption (above and below) should fix this.
> 
> I added some spacing, do you like it more?

That's better, thanks!
Attachment #8670962 - Flags: review?(aleth) → review+
(In reply to aleth [:aleth] from comment #8)
> 
> However, the real bug here is that the options in the window are not
> keyboard-accessible (i.e. if you keep pressing TAB you never get to the
> checkbox etc). That's for a separate bug though (and maybe m-c?).

On Windows this works (okay, not this dialog as it exists only on OS X). If you want access the options with the access-keys you need to press on Windows additionally SHIFT to the ALT- combinations.
Keywords: checkin-needed
(In reply to Richard Marti (:Paenglab) from comment #9)
> (In reply to aleth [:aleth] from comment #8)
> > 
> > However, the real bug here is that the options in the window are not
> > keyboard-accessible (i.e. if you keep pressing TAB you never get to the
> > checkbox etc). That's for a separate bug though (and maybe m-c?).
> 
> On Windows this works (okay, not this dialog as it exists only on OS X). If
> you want access the options with the access-keys you need to press on
> Windows additionally SHIFT to the ALT- combinations.

What access keys?

My expectation would be that (as with any other dialog) TAB cycles through the dialog elements. Instead, I can only select the close button or ?? (the background?). Shift-TAB cycles in the opposite direction as expected.

Ctrl-TAB switches between tabs.
Option-TAB and Option-Shift-TAB doesn't appear to do anything.
(In reply to aleth [:aleth] from comment #10)
> My expectation would be that (as with any other dialog) TAB cycles through
> the dialog elements. Instead, I can only select the close button or ?? (the
> background?). Shift-TAB cycles in the opposite direction as expected.

This doesn't work properly for the main in-content prefs either - only the textbox elements are reachable.
I've just checked and on Firefox Aurora I see the same behaviour.
That's pretty broken accessibility, isn't it? :-/
Yeah, OS X, or TB and FX on OS X, looks not so well accessible. I also can't access the menulists in Write window with TAB. Or I haven't found where to enable such things in OS X. Any hints?
(In reply to Richard Marti (:Paenglab) from comment #12)
> My expectation would be that (as with any other dialog) TAB cycles through
> the dialog elements. Instead, I can only select the close button or ?? (the
> background?). Shift-TAB cycles in the opposite direction as expected.

After some investigating, it turns out that this behaviour is normal on OSX unless you turn on Full Keyboard Access in Preferences->Keyboard->Shortcuts. Sorry for the false alarm!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0
(In reply to aleth [:aleth] from comment #13)
> After some investigating, it turns out that this behaviour is normal on OSX
> unless you turn on Full Keyboard Access in Preferences->Keyboard->Shortcuts.
> Sorry for the false alarm!

Ah yes, that's it. Thank you for the tip.
You need to log in before you can comment on or make changes to this bug.