OSX: Open link from external application opens second windows

RESOLVED FIXED

Status

()

Firefox
Shell Integration
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Herr Becker, Unassigned)

Tracking

Trunk
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

Clicking a link within Mail


Actual results:

Firefox opens with 2 windows. The window in front is empty, the window with the clicked URL opens in the background.



Expected results:

Only one window opens, with the URL which was shown in Mail.

Firefox 40.x did not show this behaviour.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X

Updated

3 years ago
Component: Untriaged → Shell Integration
(Reporter)

Comment 1

3 years ago
still persistent in 42.x branch
(Reporter)

Comment 2

3 years ago
still persistent in 42.x branch, but behaviour has changed: the second window now appears in the background.
I can confirm this on mac. This may be a dupe of another bug, but terms like "links, open, window" are very common in bugzilla.mozilla.org.

I'll try track down where the regression happened between 40 and 41.

More info: This happens when opening a link from any third party app.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The first nightly with this bug is February 24, 2015.
bad Version     39.0a1, Build ID     20150224030228
http://archive.mozilla.org/pub/firefox/nightly/2015/02/2015-02-24-03-02-28-mozilla-central/firefox-39.0a1.en-US.mac.dmg

The last nightly withOUT this bug is February 23, 2015.
Version     38.0a1, Build ID     20150223030231
http://archive.mozilla.org/pub/firefox/nightly/2015/02/2015-02-23-03-02-31-mozilla-central/firefox-38.0a1.en-US.mac.dmg
Version: 41 Branch → Trunk
Also note: I'm testing on Mac OS 10.11.3.
Summary: OSX 10.7.5: Open link from external application opens second windows → OSX: Open link from external application opens second windows
I'm not seeing this anymore. Can anyone else confirm?
No replies to comment 6, so I'm marking this as fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.