Open Bug 1212002 Opened 4 years ago Updated 3 years ago

Produce our own allthethings.json

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: armenzg, Assigned: F3real)

References

(Blocks 1 open bug)

Details

We have noticed issues where allthethings.json does not have valid data.

I keep getting alerted about it:
> Oct 06 09:24:21 pulse-actions app/worker1.1: ERROR: The builder Ubuntu VM 12.04 x64 mozilla-inbound debug test media-tests requested is invalid
> Oct 06 09:24:22 pulse-actions app/worker1.1: Traceback (most recent call last):

Even though we recover well we need to make allthethings.json production to be reliable so we don't get blamed for it.

I won't put this at the top of the list in case bug 1210390 gets fixed first.
I'm hoping to produce an allthethings.json in bug 1210390.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210390
Duplicate of bug: 1216677
I think we should produce our own file.

Generating it is easy:
https://hg.mozilla.org/build/braindump/file/default/community/generate_allthethings_json.sh
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
F3real wants to give this a try. I'm going to add the information I sent him (plus some additions).

The main idea is to produce allthethings.json every time a change lands on the 'production' branch of buildbot-configs repository [1]

I realize that we don't necessarily need to use Heroku app but it might be our best option. Note: Heroku can be used for free and we can move it to a paid tier if we need to.

If we manage to get some sort of messages notifying us of commits on the production branch we can then easily create the file (generate_allthethings_json.sh generates it). bug 1237811 would give us the pulse stream we need.

If we can't get a system to notify us, we might be able to try to generate the file every 15 minutes. Maybe Heroku has something like a schedule or a cron job. Or we can make the python code that calls generate_allthethings_json.sh to have a timer.

Once we generate the file, we should put it somewhere publicly accessible. With Heroku we should be fine. I've thought of Travis and TaskCluster but I'm concerned with some intrencancies that they have.

Perhaps we can start with theapproach with a schedulr and then switch to a pulse stream once bug 1237811 fixed. For now, we should see it being produce on Heroku.

[1] http://hg.mozilla.org/build/buildbot-configs
Assignee: nobody → stefan92f
Depends on: 1237811
You need to log in before you can comment on or make changes to this bug.