No wheel events fire on disabled <input> elements

RESOLVED FIXED in Firefox 47

Status

()

Core
DOM: Events
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Vergil Penkov, Assigned: smaug)

Tracking

({testcase})

44 Branch
mozilla47
testcase
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36

Steps to reproduce:

1) I used a plugin to style the scrollbar on Firefox. The plugin doesn't really matter, every mature javascript plugin behaves like demonstrated.
2) I'm having an <input type="text" disabled> (could be a textarea, also applicable on mobile devices)


Actual results:

When I hover the disabled input and use mousescroll, nothing happens.
Video: https://www.youtube.com/watch?v=7FGel8wdi9Y&hd=1


Expected results:

It should scroll like the other browsers do.

Comment 1

2 years ago
(In reply to Vergil Penkov from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML,
> like Gecko) Chrome/45.0.2454.101 Safari/537.36
> 
> Steps to reproduce:
> 
> 1) I used a plugin to style the scrollbar on Firefox. The plugin doesn't
> really matter, every mature javascript plugin behaves like demonstrated.

Can you please give a more complete testcase in a jsbin, codepen, jsfiddle, or by attaching a file or set of files to this bug?

At the moment it's not clear whether, say, that scrollbar is entirely constructed in client DOM, or whether you simply mean that the container has overflow-y: scroll or auto and there's some CSS that styles the scrollbars, or something else still. In order to reproduce and work out what the problem is, that's quite important information to have.
Component: Untriaged → Untriaged
Flags: needinfo?(drgigguls)
Keywords: testcase-wanted
Product: Firefox → Core
Component: Untriaged → General
(Reporter)

Updated

2 years ago
Flags: needinfo?(drgigguls)
(Reporter)

Comment 2

2 years ago
http://jsfiddle.net/1uzug7jn/

There's a link.
This happens with every custom scrollbar plugin.
(Reporter)

Updated

2 years ago
Component: General → General
Keywords: testcase-wanted → testcase
OS: Unspecified → All
Product: Core → Firefox
Hardware: Unspecified → All

Comment 3

2 years ago
I created a minimal-ish testcase: http://codepen.io/anon/pen/BjyxrN . Olli or Neil, do you know what's going on here?
Status: UNCONFIRMED → NEW
Component: General → DOM: Events
Ever confirmed: true
Flags: needinfo?(enndeakin)
Flags: needinfo?(bugs)
Product: Firefox → Core
Summary: Disabled inputs ignore mouse scroll → No wheel events fire on disabled <input> elements
(Assignee)

Comment 4

2 years ago
It is unspecified which events should fire on disabled elements, different browsers fire different events.
And we're too strict here.
Assignee: nobody → bugs
Flags: needinfo?(bugs)
(Reporter)

Comment 5

2 years ago
Just to further clarify, this is an issue with <textarea> elements as well. Presumably <button> also.
(Assignee)

Comment 6

2 years ago
Yes, various form elements (not talking about <form> but <input> etc as form elements.)
Flags: needinfo?(enndeakin)
(Assignee)

Comment 7

2 years ago
Created attachment 8724054 [details] [diff] [review]
patch
Attachment #8724054 - Flags: review?(bzbarsky)
(Assignee)

Comment 8

2 years ago
note, the patch affects just which events are dispatched to dom, not what is being scrolled.
Comment on attachment 8724054 [details] [diff] [review]
patch

r=me
Attachment #8724054 - Flags: review?(bzbarsky) → review+

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c728ed2a0ba9
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1263438
You need to log in before you can comment on or make changes to this bug.