Hover pseudo class in Firefox mobile

UNCONFIRMED
Unassigned

Status

()

Core
CSS Parsing and Computation
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: Ron Aitchison, Unassigned)

Tracking

41 Branch
Unspecified
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 K-Meleon/75.0
Build ID: 7500

Steps to reproduce:

Hovered and tried to use single tap over an HTML li tag as part of a CSS menu system.
Used firefox 41.0 on Sony M2 running Android 4.4.4
URL for testing if required http://newweb.zytrax.com/tech
(UA string must be normal firefox but must include'mobile' to generate content)
The menu drops down after tapping the ⊕  glyph (⊕) in top right corner of screen. This glyph contains a html a (anchor) and expands using a single tap as expected. Then tried to run down to the last element in the menu (which does not contain an html a (anchor) tag and nothing happened. 


Actual results:

The intial menu is displayed as expected when the glyph in the top right corner is tapped. This glyph is enclosed in an html a tag. When running down to the last element in the menu ('tech stuff') a tap produced no response (the underline remained active in the preceeding menu element ('company')). It was almost as if firefox mobile was not allowing access to the last menu element. This last menu element does not have a enclosing html a tag (enclosed in li tags only) - all others have a tag nested inside li tags.


Expected results:

Tapping the glyph (enclosed in a tag) does appear to trigger the hover event in spite of warnings to the contrary in 
https://developer.mozilla.org/en-US/docs/Web/CSS/%3Ahover
However nothing happens in the last element of the menu (which has no enclosing a tag). The style sheet and html code works perfectly with desktop firefox (mouse hover expands the second level menu). The exact same CSS and html works fine with a chrome browser (single tap expands the 2nd level menu). The hover behaviour (IMO) is inconsistent when used with a and other (in this case li tags)
(Reporter)

Updated

2 years ago
OS: Unspecified → Android
You need to log in before you can comment on or make changes to this bug.