crash in `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete

RESOLVED WORKSFORME

Status

()

Core
DOM: Workers
--
critical
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

({crash})

41 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(firefox41 wontfix, firefox42 wontfix, firefox43 wontfix, firefox44 wontfix, firefox45 wontfix, firefox46 affected, firefox47 affected)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-bff20e1e-c95b-4f5b-97d4-f68e82151006.
=============================================================

Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	`anonymous namespace'::ScriptLoaderRunnable::OnStreamComplete(nsIStreamLoader*, nsISupports*, nsresult, unsigned int, unsigned char const*) 	dom/workers/ScriptLoader.cpp
1 	xul.dll 	nsStreamLoader::OnStopRequest(nsIRequest*, nsISupports*, nsresult) 	netwerk/base/nsStreamLoader.cpp
2 	xul.dll 	nsJARChannel::OnStopRequest(nsIRequest*, nsISupports*, nsresult) 	modules/libjar/nsJARChannel.cpp
3 	xul.dll 	nsInputStreamPump::OnStateStop() 	netwerk/base/nsInputStreamPump.cpp
4 	xul.dll 	nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) 	netwerk/base/nsInputStreamPump.cpp
5 	xul.dll 	nsInputStreamReadyEvent::Run() 	xpcom/io/nsStreamUtils.cpp
6 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp

625 crashes in the past 28 days https://crash-stats.mozilla.com/report/list?product=Firefox&range_unit=days&range_value=28&signature=%60anonymous+namespace%27%27%3A%3AScriptLoaderRunnable%3A%3AOnStreamComplete%28nsIStreamLoader*%2C+nsISupports*%2C+nsresult%2C+unsigned+int%2C+unsigned+char+const*%29

Comment 1

2 years ago
This looks like the QI to PRUint32Supports (which should never fail, according to the debug assertion) is failing: http://hg.mozilla.org/releases/mozilla-release/annotate/78c82e5cd777/dom/workers/ScriptLoader.cpp#l567
Component: Networking → DOM: Workers

Comment 2

2 years ago
Er, nsISupportsPRUint32 that is.

Updated

2 years ago
Crash Signature: [@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete(nsIStreamLoader*, nsISupports*, nsresult, unsigned int, unsigned char const*)] → [@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete(nsIStreamLoader*, nsISupports*, nsresult, unsigned int, unsigned char const*)] [@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete]
Dupe of bug 1060719?
Flags: needinfo?(mcmanus)
See Also: → bug 1253793
this really is a dom:workers bug, so I think 1060719 and 1253793 should be dupd to this
Flags: needinfo?(mcmanus)
Duplicate of this bug: 1060719
Duplicate of this bug: 1253793
(In reply to Patrick McManus [:mcmanus] from comment #4)
> this really is a dom:workers bug, so I think 1060719 and 1253793 should be
> dupd to this

Let's leave bug 1253793 open for the sake of Treeherder starring.
Blocks: 1253793
status-firefox41: affected → wontfix
status-firefox42: affected → wontfix
status-firefox43: affected → wontfix
status-firefox44: --- → wontfix
status-firefox45: --- → wontfix
status-firefox46: --- → affected
status-firefox47: --- → affected
See Also: bug 1060719, bug 1253793

Comment 8

2 years ago
Note, we have not had an instance of this crash since 44 as far as I can tell:

  https://crash-stats.mozilla.com/signature/?signature=%60anonymous+namespace%27%27%3A%3AScriptLoaderRunnable%3A%3AOnStreamComplete&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&page=1#reports

  https://crash-stats.mozilla.com/signature/?signature=ScriptLoaderRunnable%3A%3AOnStreamComplete&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&page=1#reports
Component: DOM: Workers → DOM: Service Workers

Comment 9

2 years ago
Actually, this particular method gets called for any worker script load.  It may still be related to service workers, though.  I'll take a look.
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Component: DOM: Service Workers → DOM: Workers
its hard for me to look right now, but iirc one of the issues I dup'd to this predated service workers entirely.. fwiw

Comment 11

2 years ago
If have a stack of service worker bugs to look at, so unassigning myself here.  Kyle, can you look at this or have ideas of someone else to investigate?
Assignee: bkelly → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(khuey)
We always seem to be loading from a JAR channel when it happens, which is interesting.

Where is this on the top crash list?  Is it worth prioritizing?
Flags: needinfo?(khuey) → needinfo?(kairo)

Comment 13

2 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #12)
> Where is this on the top crash list?  Is it worth prioritizing?

It's pretty low volume, not in the top 50 crashes on release.
Flags: needinfo?(kairo)
Summary: crash in `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete(nsIStreamLoader*, nsISupports*, nsresult, unsigned int, unsigned char const*) → crash in `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete
(Reporter)

Comment 14

a year ago
[@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete(nsIStreamLoader*, nsISupports*, nsresult, unsigned int, unsigned char const*)] has gone away completely.

[@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete] has 16 crashes in the past week, but the most recent version is Firefox 44.0b7
Status: NEW → RESOLVED
Crash Signature: [@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete(nsIStreamLoader*, nsISupports*, nsresult, unsigned int, unsigned char const*)] [@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete] → [@ `anonymous namespace''::ScriptLoaderRunnable::OnStreamComplete]
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.