Assignee AJAX is not suitably debounced

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: github, Unassigned)

Tracking

5.0.1

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

1. Opened or started a new bug.
2. Focussed on the assignee field.
3. Typed a name as quick as I could.



Actual results:

Multiple requests were sent to the server and with our low powered VM this resulted in multiple executions of the jsonp handler that slowed down the response.


Expected results:

Use timeout to prevent the request firing for a short period of time, cancel the timeouts each time the event handler is called.  Only make the JSON request if the timeout fires, and therefore only one request.

Comment 1

3 years ago
This is done already. In 5.0 and before, the delay is 0.05s: userAutoComp.queryDelay = 0.05.
Since 5.1, the delay is 0.25s: deferRequestBy: 250.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.