www.lunarstorm.se - Mozilla can't open image links

VERIFIED FIXED

Status

Tech Evangelism Graveyard
Other
P3
minor
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Gustav, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [eurocontest], URL)

(Reporter)

Description

16 years ago
This is a fairly large website in Europe. Mozilla can't open pictures because
they seems to be interpreted as .asf files. Another minor thing is that they
generally use the ALT= property for iamges and links though it's obvious that
they would aim the TITLE= function. 
Disclaimer: that particular user was chosen on random so please don't message
him or so

1. Go to www.lunarstorm.se
2. user: tryout & password: aspasp
3. Go to the box at the bottom/right that says "snabbsök" and enter for
instance: feber
4. A new page, press the red "PRYLAR" button
5. There's a list of his pictures (they should all be jpeg's or possibly bmp's,
although I think they're embedded in an .asp file)
6. Click on any of the picture headings
7. Now there should be a dialogue for whether you want to open or save, notice
that the mime type is application/x-lsdownload
8. By trying the "Advanced" button, you could see that it's an .asf file
9. Saving works fine, it then seems to swap so that it's a jpeg that's saved
10. But if you choose "Open" then it asks for an associated program (although I
have already an associated program for jpeg's) The thing is that now there's an
.asf file it tries to open, not a jpeg which it should be. I'm not really sure
if it's a wrong design.

info@lunarworks.se (corporate)
support@lunarstorm.se (user support)

Comment 1

16 years ago
-> TE
(Reporter)

Comment 2

16 years ago
Also check out the link now added to "URL".
It's a different site - but it seems to be closely related.
If you click on the "klagomÄlsblankett" link to the right, apart from that it
opens a new window, the save dialogue appears...
If you press "Advandced" you can see that it's an 'application/pdf' with a pdf
extension. But if you choose to save the file, the following dialogue wants to
save 'getFile.asp'.

Comment 3

16 years ago
Confirmed
2002022203/WinXP

Notes:
Author also needs to specify character set.  My default is UTF-8 so the
characters are incorrectly interpreted with lots of question marks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
Confirming bug with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8)
Gecko/20020204 (and the same version on Mac OSX)

Setting Platform->All

the JPG file is not JPG in fact. It contains a string which is "An error
occurred on the server when processing the URL.  Please contact the system
administrator."

setting P3.

Tried with IEMac to reproduce the bug, but IE does nothing when clicking on the
picture link...
Priority: -- → P3
Hardware: PC → All
Whiteboard: [eurocontest]
(Reporter)

Comment 5

16 years ago
Have you received any response from the webmaster? What do they say?
(Reporter)

Comment 6

16 years ago
What happens now is that also when you save the file,
it is treated as an .asp -file, and thus given the .asp file extension.
Before, you could at least save the picture as .jpg without modifying the target
file name.
(Reporter)

Comment 7

16 years ago
I think this is a duplicate of 120327. Can anyone verify?
(Reporter)

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 120327 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
Reopening, I was wrong.
Severity: normal → minor
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 10

15 years ago
It's fixed, just don't know how & when...
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.