Closed Bug 1212499 Opened 4 years ago Closed 4 years ago

Pass the correct TextureClient backend in CanvasClient

Categories

(Core :: Graphics: Layers, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox42 --- fixed
firefox43 --- fixed
firefox44 --- fixed

People

(Reporter: dvander, Assigned: dvander)

References

Details

Attachments

(1 file)

No description provided.
Attached patch fixSplinter Review
Attachment #8670940 - Flags: review?(matt.woodrow)
Attachment #8670940 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/7a6ec4430c07
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Any uplifts that are warranted here?
Comment on attachment 8670940 [details] [diff] [review]
fix

Approval Request Comment
[Feature/regressing bug #]: bug 1183910
[User impact if declined]: Potential rendering glitches in 2D canvas on Mac/Linux.
[Describe test coverage new/current, TreeHerder]: Nightly
[Risks and why]: Low risk. This is reverting to behavior in Firefox 41, which was broken in Firefox 42 by accident.
[String/UUID change made/needed]:
Attachment #8670940 - Flags: approval-mozilla-beta?
Attachment #8670940 - Flags: approval-mozilla-aurora?
To clarify: the bug is that we selected the wrong 2D backend to render 2D canvases, on Mac/Linux, which could result in an unsupported Graphics configuration.
Comment on attachment 8670940 [details] [diff] [review]
fix

Improve the graphic situation, taking it. Should be in 42 beta 6.
Attachment #8670940 - Flags: approval-mozilla-beta?
Attachment #8670940 - Flags: approval-mozilla-beta+
Attachment #8670940 - Flags: approval-mozilla-aurora?
Attachment #8670940 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 1212790
You need to log in before you can comment on or make changes to this bug.