Product and Component vs "My Requests"

RESOLVED DUPLICATE of bug 199516

Status

()

Bugzilla
Attachments & Requests
RESOLVED DUPLICATE of bug 199516
3 years ago
3 years ago

People

(Reporter: Christophe JAILLET, Unassigned)

Tracking

4.4.7

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

Hi,

while looking at a translation issue in a localised version of bugzilla, I noticed something odd in the way "My request" can be filtered.

The interface allows to select "Any" Product and a given "Component".
Fine.

However, the code in request.cgi, around line 205 seems to only consider "Component" if a "Product" has been selected.

So I guess, that if only a "Component" is selected, the filter will behave just as if none was selected and that this part of the filter will be silently discarded.

I'm not able to test it right now in order to confirm the behaviour (we don't use flags)



Expected results:

If I'm correct, users should not be able to select a component if no product is selected, *or* the code should be able to handle this case.

Comment 1

3 years ago
Very old story. :)
Assignee: general → attach-and-request
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Bugzilla-General → Attachments & Requests
Resolution: --- → DUPLICATE
Duplicate of bug: 199516
You need to log in before you can comment on or make changes to this bug.