Conversation controls look bad

VERIFIED FIXED in Firefox 44

Status

Hello (Loop)
Client
P1
normal
Rank:
9
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

unspecified
mozilla44
regression
Points:
---

Firefox Tracking Flags

(firefox44 verified)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Created attachment 8671277 [details]
Bad layout

This is a regression from bug 1209632 that I should have caught when reviewing.

The layout of the conversation icons for the controls now looks bad - see attached screenshot
(Assignee)

Comment 1

3 years ago
Created attachment 8671282 [details] [diff] [review]
Revert Loop's conversation toolbar button sizes due to bug 1209632 causing a visual regression.

This reverts the size of the buttons to what they were before and fixes the layout. Screenshots coming up in a moment.
(Assignee)

Comment 2

3 years ago
Created attachment 8671286 [details]
Standalone view with original sized buttons

Sevaan: What do you think about reverting the conversation toolbar button sizes to the original - 28px high, 33px wide - rather than 24px by 24px.

We can do the work to make them smaller, but I think we'll need a new background for the mute buttons, and we might need a little more work to get the placement right. Not saying we can't/won't do it. Just seeing what the options are.
Attachment #8671286 - Flags: ui-review?(sfranks)
(Assignee)

Updated

3 years ago
Assignee: nobody → standard8
(Assignee)

Comment 3

3 years ago
Created attachment 8671287 [details]
Desktop conversation window with original sized buttons
Attachment #8671287 - Flags: ui-review?(sfranks)
(In reply to Mark Banner (:standard8) from comment #2)
> Created attachment 8671286 [details]
> Standalone view with original sized buttons
> 
> Sevaan: What do you think about reverting the conversation toolbar button
> sizes to the original - 28px high, 33px wide - rather than 24px by 24px.
> 
> We can do the work to make them smaller, but I think we'll need a new
> background for the mute buttons, and we might need a little more work to get
> the placement right. Not saying we can't/won't do it. Just seeing what the
> options are.

Sure, I think that's okay to have the original size at the moment.
Attachment #8671286 - Flags: ui-review?(sfranks) → ui-review+
Comment on attachment 8671286 [details]
Standalone view with original sized buttons

+r but can we fix the margin on the left of the leave button to match the margin on the right of the Mozilla logo?
Comment on attachment 8671287 [details]
Desktop conversation window with original sized buttons

We should move the inset video in more to match the left and bottom margins of the control buttons.
Attachment #8671287 - Flags: ui-review?(sfranks) → ui-review+

Updated

3 years ago
Iteration: --- → 44.2 - Oct 19
Rank: 9
Priority: -- → P1
(Assignee)

Comment 7

3 years ago
Created attachment 8671574 [details] [diff] [review]
Revert Loop's conversation toolbar button sizes due to bug 1209632 causing a visual regression.

This does the backout and also fixes the insert for the conversation toolbar - the hangup button was taking more width than it needed to. We can't change the width of the other buttons, but we can fix the width of just the hangup button.
Attachment #8671282 - Attachment is obsolete: true
Attachment #8671574 - Flags: review?(dmose)
Comment on attachment 8671574 [details] [diff] [review]
Revert Loop's conversation toolbar button sizes due to bug 1209632 causing a visual regression.

Review of attachment 8671574 [details] [diff] [review]:
-----------------------------------------------------------------

r=dmose with added comment

::: browser/components/loop/content/shared/css/conversation.css
@@ +60,1 @@
>  }

Please add a comment explaining why this override is necessary.
Attachment #8671574 - Flags: review?(dmose) → review+
https://hg.mozilla.org/mozilla-central/rev/4a9f34794678
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Flags: qe-verify+
QA Contact: bogdan.maris
Created attachment 8682543 [details]
Screencast showing the issue

I can still see some issues with the controls after clicking on them both conversation and standalone, should I log a new bug on this?
Flags: needinfo?(standard8)
(Assignee)

Comment 12

3 years ago
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #11)
> Created attachment 8682543 [details]
> Screencast showing the issue
> 
> I can still see some issues with the controls after clicking on them both
> conversation and standalone, should I log a new bug on this?

Yes please, I'm thinking they are possibly windows only as I've not seen them on this Mac.
Flags: needinfo?(standard8)
(In reply to Mark Banner (:standard8) from comment #12)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #11)
> > Created attachment 8682543 [details]
> > Screencast showing the issue
> > 
> > I can still see some issues with the controls after clicking on them both
> > conversation and standalone, should I log a new bug on this?
> 
> Yes please, I'm thinking they are possibly windows only as I've not seen
> them on this Mac.

It reproduces across platforms (Windows 7 64-bit, Windows 10 64-bit, Mac OS X 10.11.1, Ubuntu 14.04 32-bit) but Firefox needs to be restarted before a call or use a clean profile.
Logged bug 1221486.

Also closing this bug since the initial issue with the wrong placement of the controls was verified across platforms using latest Firefox Developer Edition 44.0a1.
Status: RESOLVED → VERIFIED
status-firefox44: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.