Closed Bug 1212791 Opened 7 years ago Closed 7 years ago

[Music NGA]Search bar is not visible in Playlist views in Music app.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: huxiaoyan, Assigned: justindarc)

References

Details

(Whiteboard: [2.5-aries-test-run-3])

Attachments

(4 files)

[1.Description]:
[Flame KK_v2.5][Aries KK_v2.5][Music] Launch music app and switch to the Playlist View to observe,  there isn't Search bar in Playlist views .
Time: 17:01
See attachments: logcat_1701.txt and Aries_KK_v2.5.3gp.

[2.Testing Steps]: 
Precondition: There are some songs on the DUT.
1. Open the music app.
2.Toggle on Playlist View, Artist View, and Album View  to observe whether the Search bar.

[3.Expected Result]: 
2. Search bar should be visible in all views .

[4.Actual Result]: 
2. Search bar is not visible in Playlist views .

[5.Reproduction build]: 
Device: Aries KK 2.5 (Affected)
Build ID               20151008002716
Gaia Revision          b99837aa2294348317bcae68acabe71d9a83d774
Gaia Date              2015-10-07 13:04:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c6ede6f30f3dc886543bb1c76fd7c8b5a151786b
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151007.234555
Firmware Date          Wed Oct  7 23:46:03 UTC 2015
Bootloader             s1

Device: Flame KK 2.5 (Affected)
Build ID               20151007150205
Gaia Revision          b99837aa2294348317bcae68acabe71d9a83d774
Gaia Date              2015-10-07 13:04:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1e1fa696e2b626ead6817b7c5bd871fec5d5ab5a
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151007.183338
Firmware Date          Wed Oct  7 18:33:51 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2 (Unaffected)
Build ID               20151007032507
Gaia Revision          5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gaia Date              2015-09-21 11:20:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b48f0cd1bc45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151007.064847
Firmware Date          Wed Oct  7 06:48:58 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
2355
Attached video Aries_KK_v2.5.3gp
Attached file logcat_1701.txt
Summary: [Music]Search bar is not visible in Playlist views in Music app. → [Music NGA]Search bar is not visible in Playlist views in Music app.
Hi, Annabelle,

Good day.

Can it be reproduced on old Music app?
Thank you.
Flags: needinfo?(huxiaoyan)
Assignee: nobody → jdarcangelo
Depends on: 1209438
Comment on attachment 8672641 [details] [review]
[gaia] justindarc:bug1212791 > mozilla-b2g:master

This depends on the patch in Bug 1209438 so there are 2 commits in this PR.
Attachment #8672641 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8672641 [details] [review]
[gaia] justindarc:bug1212791 > mozilla-b2g:master

Seems sane, although I don't remember off-hand whether OGA does this. In any case, this view is (sort of) going away in 3.0, so it doesn't matter too much.
Attachment #8672641 - Flags: review?(squibblyflabbetydoo) → review+
Duplicate of this bug: 1213942
Status: NEW → ASSIGNED
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/879b8d17e2082779b99917e507097d4aef34b79c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Hi Shally, 

Could you help to verify this bug? Also help to check comment 3. thanks. :)
Flags: needinfo?(huxiaoyan) → needinfo?(lixia)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: Search bar is available/visible in Playlist views in NGA Music app.
See attachment: verified_(OGA&NGA music)Flame_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151014150203
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151014.183316
Firmware Date          Wed Oct 14 18:33:28 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151014225836
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151014.221548
Firmware Date          Wed Oct 14 22:15:56 UTC 2015
Bootloader             s1

-------------------------------------------------------------------
(In reply to William Hsu [:whsu] from comment #3)
> Hi, Annabelle,
> 
> Can it be reproduced on old Music app?
> Thank you.

This bug can't be repro on old Music app (OGA music), thanks.
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(lixia)
You need to log in before you can comment on or make changes to this bug.