Closed Bug 1212858 Opened 5 years ago Closed 5 years ago

Cannot load content in Safe Mode because OMTC is disabled

Categories

(Core :: Graphics, defect)

42 Branch
Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1187322
Tracking Status
e10s ? ---
firefox41 --- unaffected
firefox42 --- unaffected
firefox43 --- affected
firefox44 --- affected

People

(Reporter: beingalink, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151008030232

Steps to reproduce:

Open Firefox in normal Mode.
In the Burger Menu click "? (Help)" --> Restart with Add-ons Disabled
Confirm


Actual results:

Firefox starts in Safe Mode but no Content gets displayed. The content seems to get loaded though since the spinners on the tabs work as if everything was normal. In the content section there is only a spinner in front of grey background (see screenshot attached to this bug)


Expected results:

Content should display normally in safe mode.
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
I can confirm. It looks like safe mode disables OMTC again, and without OMTC we can't display anything from the content process.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't reproduce this on Windows or Linux. Looks like we'll need someone to bisect on a Mac.
Component: Untriaged → Graphics
Product: Firefox → Core
Hardware: x86_64 → Unspecified
I can reproduce this in today's Nightly build -- working now on finding the regression window.
QA Contact: anthony.s.hughes
It looks like this was caused by bug bug 1179051 (cc dvander).

Pushlog:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=15155971639c&tochange=9c919ce631ea
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e673cc171604a05f6d1cde745b5d7c61074be342&tochange=08508716085a41245854b88d5e1f13b315a5ab4f

[Tracking Requested - why for this release]: Mac OS users running in safe mode will not be able to render any web content. This should probably block release of Firefox 42 given that running in safe mode is a common troubleshooting step.
Depends on: 1179051
Flags: needinfo?(dvander)
Summary: Safe Mode is broken in Firefox Nightly → Cannot load content in Safe Mode because OMTC is disabled
Version: 44 Branch → 42 Branch
Markus, around when bug 1179051 landed we had turned off BasicCompositor on Mac. Did we reverse that decision?

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #4)
> It looks like this was caused by bug bug 1179051 (cc dvander).
> 
> Pushlog:
> > https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=15155971639c&tochange=9c919ce631ea
> > https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e673cc171604a05f6d1cde745b5d7c61074be342&tochange=08508716085a41245854b88d5e1f13b315a5ab4f
> 
> [Tracking Requested - why for this release]: Mac OS users running in safe
> mode will not be able to render any web content. This should probably block
> release of Firefox 42 given that running in safe mode is a common
> troubleshooting step.

Can you actually reproduce this on 42? I would think this is E10S only.
Flags: needinfo?(dvander) → needinfo?(mstange)
(In reply to David Anderson [:dvander] from comment #5)
> Can you actually reproduce this on 42? I would think this is E10S only.

You are correct. This reproduces in Firefox 42 builds where e10s is enabled (ie. Nightly) but not where it is disabled (ie. Beta). Therefore I reverse my red-flag for blocking release, definitely should block e10s though.
Blocks: 1187859
Duplicate of this bug: 1225061
clearing NI to get back into triage.  Should be an m8+ because of useless Safe Mode.
Flags: needinfo?(mstange)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1187322
You need to log in before you can comment on or make changes to this bug.