Remove support for the legacy oauth credentials

RESOLVED FIXED

Status

Tree Management
Treeherder: API
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

Details

Attachments

(1 attachment)

Once bug 1212936 has migrated all user of legacy oauth credntials, we can remove support, including that pesky credentials.json file and credentials columns on the datasource table :-)
Created attachment 8677721 [details] [review]
Remove support for OAuth credentials

Will request review nearer to when the last of the submitters are due to migrate to Hawk credentials.
Status: NEW → ASSIGNED
Comment on attachment 8677721 [details] [review]
Remove support for OAuth credentials

It's too early to land, but we can get the review out of the way at least :-)
(Absolutely no rush).
Attachment #8677721 - Flags: review?(mdoglio)
Attachment #8677721 - Flags: review?(mdoglio) → review+

Comment 3

3 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/3a5784d14c7863a840fe9e02937d09b42b2b139c
Bug 1212937 - Rename OAuthLoaderMixin to ClientLoaderMixin

Since the name is no longer accurate.

https://github.com/mozilla/treeherder/commit/61d596267a5b23c1295092b30f0efd5318e1ce6e
Bug 1212937 - Remove API support for OAuth credentials

Since they are deprecated and all submitters have switched over to using
Hawk credentials instead.

The automatically created migrations file was edited to remove the
unused `models` import, since otherwise flake8 complains. We could
alternatively exclude the migrations directory from flake8, however we
would then miss linter errors in any hand-written migrations files.

In addition, Django have fixed the issue in 1.9:
https://github.com/django/django/commit/a7bc00e17bebe34cdf23f744937b3c386ee73d81

https://github.com/mozilla/treeherder/commit/527a8f9947cc9db93373a8232fb27b59700e9528
Bug 1212937 - Remove Python client support for OAuth credentials

Since they are deprecated and no longer supported by the API.
The Python client version will be bumped in a later commit.

https://github.com/mozilla/treeherder/commit/17b514d32e91270a76cd4a8f4bf54e24e98a4492
Bug 1212937 - Remove support for passing `auth` to the Python client

The `auth` parameter was intended to receive either a `TreeherderAuth`
instance (for OAuth credentials), or a `HawkAuth` instance. The former
no longer exists since OAuth support has been removed, and the latter is
not necessary, since the client now supports simply passing `client_id`
and `secret` to the `TreeherderClient` constructor, as a simpler way of
specifying the Hawk credentials. As such, the `auth` parameter is
superfluous and can be removed.

https://github.com/mozilla/treeherder/commit/a7bc7815e6cc198dbcdc73e269bb0634b1a19c08
Bug 1212937 - Bump the Python client to v2.0.0

The changes since v1.8.0 (`auth` parameter / OAuth removal) are
potentially breaking, so bumping the major version, in line with SemVer.
\o/
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Blocks: 1236957
You need to log in before you can comment on or make changes to this bug.