Firefox Beta doesn't allow unclicking the "Don't ask again for this site" checkbox when a site requests your location

RESOLVED DUPLICATE of bug 1193337

Status

()

RESOLVED DUPLICATE of bug 1193337
3 years ago
3 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

42 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox41 unaffected, firefox42 affected, firefox43 unaffected, firefox44 unaffected, fennec42+)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

Went to Google.com, attempted to uncheck the "Don't ask again for this site" checkbox on the "Share your location" popup


Actual results:

Nothing. Pressing on the checkbox never changes it. It's always checked.


Expected results:

It should have unchecked that box
Blocks: 1169425
I can only reproduce this in Aurora and Beta. Workaround seems to be rotating the device. However that only works for one tap. Then the checkbox is nonresponsive to touches again.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
status-firefox41: --- → unaffected
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox44: --- → unaffected
tracking-firefox42: --- → ?
tracking-firefox43: --- → ?
Ever confirmed: true
Keywords: regression
I wonder if this is a regression of bug 1193337
Summary: An Android Marshmallow, Firefox Beta doesn't allow unclicking the "Don't ask again for this site" checkbox when a site requests your location → On Android Marshmallow, Firefox Beta doesn't allow unclicking the "Don't ask again for this site" checkbox when a site requests your location
I can reproduce this on Android 5.0 as well. Steps to reproduce

* load google.com
* if the door hanger for location does not appear scroll down and tap use precise location
* attempt to tap the check box in the geoloction door hanger

Expected: checkbox toggles from checked to unchecked
Actual: taps do not toggle the checkbox

When verifying this bug we should test as many devices as possible as well as other door hangers that have checkboxes. Might need assistance from the dev team to enumerate the door hangers.
Summary: On Android Marshmallow, Firefox Beta doesn't allow unclicking the "Don't ask again for this site" checkbox when a site requests your location → Firefox Beta doesn't allow unclicking the "Don't ask again for this site" checkbox when a site requests your location
Hm. Nope it is a duplicate of bug 1193337 as that has only landed on Firefox 43. We need to weigh fixing this vs. the regression bug 1201081. Tested build from http://hg.mozilla.org/mozilla-central/rev/ff71dfc40c70 and the issue reproduces, the next checkin https://hg.mozilla.org/mozilla-central/rev/2b21997e3278 does resolve the issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193337
Used 42a2 to test aurora. Updating to 43a2 fixes this.
status-firefox43: affected → unaffected
Since we already have a patch and uplift request to beta 42 in bug 1193337, I don't think we need to track this now.
tracking-firefox42: ? → ---
tracking-firefox43: ? → ---
tracking-fennec: ? → 42+
You need to log in before you can comment on or make changes to this bug.