bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Copy generated API tokens hard with extra space

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression])

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Created attachment 8671500 [details]
Screenshot 2015-10-08 11.06.52.png

There is now a space between the first part and the second part of a generated token. 

See attached screenshot. NOTE! This is a screenshot FROM MY LAPTOP INSTANCE so it's not a reveal of an actual token.
(Assignee)

Comment 1

3 years ago
Created attachment 8671502 [details]
Screenshot 2015-10-08 11.07.44.png

Notice the space when I hightlight it.
(Assignee)

Comment 2

3 years ago
Adrian, is this worth fixing now that we're getting the new personal/"you" page?
Flags: needinfo?(adrian)
Whiteboard: [regression]
Yes, that is still important to fix, because the new Profile page only shows your list of existing tokens, but still leads you to the API Tokens page for management.
Flags: needinfo?(adrian)
(Assignee)

Updated

3 years ago
Assignee: nobody → peterbe

Comment 5

3 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/3604b02c58dd9f37a7e2d14cef6b4601ff99e4d3
fixes bug 1212969 - display copyable token without whitespace

https://github.com/mozilla/socorro/commit/b4f2a1fa6f65c5967cdfae6eb1bb22eb0779a068
Merge pull request #3032 from peterbe/bug-1212969-display-copyable-token-without-whitespace

fixes bug 1212969 - display copyable token without whitespace

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
It didn't work. :(

Visually the whole token might look sane but when you paste it (after having copied it) it still has the space in it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

3 years ago
Created attachment 8673266 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3034
Attachment #8672721 - Attachment is obsolete: true

Comment 8

3 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/4eec3c4bec3a40ebfb1eff51c5e1765c405a273b
fixes bug 1212969 - show API tokens with javascript, r=AdrianGaudebert

https://github.com/mozilla/socorro/commit/4ce00f1cc15b21303217a46246ef388c1992ef81
Merge pull request #3034 from peterbe/bug-1212969-show-api-tokens-with-javascript

fixes bug 1212969 - show API tokens with javascript
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.