crash holding down ctrl-shift-r with large standalone image

RESOLVED INVALID

Status

()

Core
Graphics
P3
normal
RESOLVED INVALID
2 years ago
6 months ago

People

(Reporter: tnikkel, Assigned: aosmond)

Tracking

({crash, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

2 years ago
Load the image from the testcase in bug 1208936 in a debug build on Windows. Hold ctrl-shift-R. Eventually I get a crash:

>	xul.dll!mozilla::gfx::SourceSurfaceAlignedRawData::~SourceSurfaceAlignedRawData() Line 88	C++
 	[External Code]	
 	xul.dll!mozilla::detail::RefCounted<mozilla::gfx::SourceSurface,1>::Release() Line 145	C++
 	xul.dll!mozilla::image::RasterImage::CopyFrame(unsigned int aWhichFrame, unsigned int aFlags) Line 668	C++
 	xul.dll!mozilla::image::RasterImage::GetFrameInternal(unsigned int aWhichFrame, unsigned int aFlags) Line 740	C++
 	xul.dll!mozilla::image::RasterImage::GetFrame(unsigned int aWhichFrame, unsigned int aFlags) Line 701	C++
 	xul.dll!nsWindowGfx::CreateIcon(imgIContainer * aContainer, bool aIsCursor, unsigned int aHotspotX, unsigned int aHotspotY, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> aScaledSize, HICON__ * * aIcon) Line 587	C++
 	xul.dll!mozilla::widget::TaskbarTabPreview::SetIcon(imgIContainer * icon) Line 95	C++
 	xul.dll!NS_InvokeByIndex(nsISupports * that, unsigned int methodIndex, unsigned int paramCount, nsXPTCVariant * params) Line 71	C++
 	xul.dll!CallMethodHelper::Invoke() Line 2095	C++
 	xul.dll!CallMethodHelper::Call() Line 1417	C++
 	xul.dll!XPCWrappedNative::CallMethod(XPCCallContext & ccx, XPCWrappedNative::CallMode mode) Line 1382	C++
 	xul.dll!XPC_WN_GetterSetter(JSContext * cx, unsigned int argc, JS::Value * vp) Line 1173	C++
 	xul.dll!js::jit::DoCallNativeSetter(JSContext * cx, JS::Handle<JSFunction *> callee, JS::Handle<JSObject *> obj, JS::Handle<JS::Value> val) Line 8207	C++
 	[External Code]	
 	[Frames below may be incorrect and/or missing]
Keywords: crash, reproducible
Whiteboard: [gfx-noted]

Updated

2 years ago
Crash Signature: [@ mozilla::gfx::SourceSurfaceAlignedRawData::~SourceSurfaceAlignedRawData]
it'd be good to see if this went away with all the recent imagelib work.
Assignee: nobody → aosmond
Priority: -- → P3
(Assignee)

Comment 2

6 months ago
This problem went away as part of bug 1290682 because RasterImage::CopyFrame was removed. The problem was that in the error cases we didn't unmap the source surface we created, and we tripped the mapping assert (which wants no mappings when freeing the surface).
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Depends on: 1290682
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.