If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Please implement HTMLElement.outerHTML

VERIFIED DUPLICATE of bug 92264

Status

()

Core
DOM
--
enhancement
VERIFIED DUPLICATE of bug 92264
16 years ago
5 years ago

People

(Reporter: Ramón García Fernández, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Please implement the Internet Explorer extension outerHTML.

I know that it hurts to implement a non-standard feature. But we are in a
unfortunate situation where Mozilla/Netscape 6 is only about 1 % of hits.
So there is very little incentive for authors of Web content to be compatible.
with standards (I tried).
(Reporter)

Comment 1

16 years ago
A description of outerHTML is in:

http://msdn.microsoft.com/workshop/author/dhtml/reference/properties/outerhtml.asp

Comment 2

16 years ago
This suggestion has been brought up in the past.  Here are the queries which 
matches OuterHTML in the description field:
http://bugzilla.mozilla.org/buglist.cgi?email1=&emailtype1=substring&emailassign
ed_to1=1&email2=&emailtype2=substring&emailreporter2=1&bugidtype=include&bug_id=
&changedin=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&product=Browser&shor
t_desc=&short_desc_type=allwordssubstr&long_desc=outerHTML&long_desc_type=allwor
dssubstr&bug_file_loc=&bug_file_loc_type=allwordssubstr&status_whiteboard=&statu
s_whiteboard_type=allwordssubstr&keywords=&keywords_type=anywords&field0-0-0=noo
p&type0-0-0=noop&value0-0-0=&cmdtype=doit&namedcmd=bugs+for+triage&newqueryname=
&order=Bug+Number

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=92264

*** This bug has been marked as a duplicate of 92264 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: lchiang → ian
v
Status: RESOLVED → VERIFIED
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.