Notifications received at the lockscreen while the screen is on will not show timestamp.

VERIFIED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Marty, Assigned: gandalf)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8671646 [details]
logcat_lockscreen.txt

Notifications are accompanied by a timestamp, indicating when they were received (Now, 3 minutes ago, etc.).

If a notification is present on the lockscreen before the screen it turned on, the timestamp will display properly, however if the screen is already on, at the lockscreen, when a notification is triggered, the timestamp will not be displayed.

Notes:
-This only occurs right when the notification was received, and if the device screen is already on.  If the screen wakes up when receiving the notification, the timestamp will display properly.
-Additionally, if the device screen is turned off, then back on, the timestamp will then appear properly for the previously affected notification.
-Timestamps are always displayed properly for notifications displayed in the Utility Tray, even those just received while viewing the notifications.

Repro Steps:
1) Update a Aries to 20151008143352
2) Lock the device. Ensure the screen is off.
3) Send an SMS to the device, note that the resulting notification will display a timestamp.
4) Send a second SMS to the device, ensuring that the device screen is on when it is received.

Actual:
The newly received notification does not display a timestamp on the lockscreen.

Expected:
Notifications always display timestamps on the lockscreen.

Environmental Variables:
Device: Aries 2.5
BuildID: 20151008143352
Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
Gecko: 1f4cf75c894862cf3634d6014d8de9c807a054a7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0


Repro frequency: 10/10
See attached: Video (URL), Logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on the latest Flame 2.5 Master build.
The newly received notification does not display a timestamp on the lockscreen.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151006030203
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 3edc8d4a1e198314f5d7ebd2967b85842beef602
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

*******************************************

This issue does NOT occur on the latest Flame 2.2 build.
Notifications always display timestamps on the lockscreen.

Environmental Variables:
Device: Flame 2.2
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
I think timestamps are important to the user so nominating to block on this. Let's get a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted

Updated

2 years ago
QA Contact: jthomas

Comment 3

2 years ago
B2g Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150911010749
Gaia: 758c75ee087ea3722213ea2c185cca1d952c8a29
Gecko: b0c1649e39d2a3cf468f2c9098288aaf177f44ec
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150911013348
Gaia: 676caf58c4de93ba0d6a93add4d0a2ebfaa67764
Gecko: 9ffed368080b29578af206e0876d6a5776efd669
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken Gecko
Gaia: 758c75ee087ea3722213ea2c185cca1d952c8a29
Gecko: 9ffed368080b29578af206e0876d6a5776efd669

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia.
Gecko: b0c1649e39d2a3cf468f2c9098288aaf177f44ec
Gaia: 676caf58c4de93ba0d6a93add4d0a2ebfaa67764

B2g Inbound Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/758c75ee087ea3722213ea2c185cca1d952c8a29...676caf58c4de93ba0d6a93add4d0a2ebfaa67764

This issue may be caused by changes made by Bug 1203348
Blocks: 1203348
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
(Assignee)

Comment 4

2 years ago
Taking
Assignee: nobody → gandalf
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Created attachment 8672159 [details] [review]
[gaia] zbraniecki:1213083-use-relativeDate-formatElement-in-system > mozilla-b2g:master
(Assignee)

Comment 6

2 years ago
Comment on attachment 8672159 [details] [review]
[gaia] zbraniecki:1213083-use-relativeDate-formatElement-in-system > mozilla-b2g:master

Ha, that's sneaky. So, System notification gets cloned to lockscreen, so we can't use async methods here too much.

Fortunately, we now have mozIntl._gaia.RelativeDate().formatElement which formats the element synchronously letting MutationObserver do the localization, which is what we really want here. :)
Attachment #8672159 - Flags: review?(apastor)
Comment on attachment 8672159 [details] [review]
[gaia] zbraniecki:1213083-use-relativeDate-formatElement-in-system > mozilla-b2g:master

LGTM. Thanks!
Attachment #8672159 - Flags: review?(apastor) → review+
(Assignee)

Comment 8

2 years ago
Commit: https://github.com/mozilla-b2g/gaia/commit/b5b5aa5e98a2979a73e5e2bab6b69daab7880a41
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Created attachment 8674161 [details]
Verified_Flame_kk_v2.5.3gp

This bug has been verified as "pass" on the latest Aires KK 2.5 and Flame KK 2.5 by the STR in comment 0.

Actual results: Ensuring that the device screen is on when SMS is received, the newly received notification always displays a timestamp on the lockscreen.


See attachment: Verified_FlameKK_v2.5_FM.3gp
Reproduce rate: 0/10


Device: Aries KK v2.5 (Pass)
Build ID               20151014225836
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151014.221548
Firmware Date          Wed Oct 14 22:15:56 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 (Pass)
Build ID               20151014150203
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151014.183316
Firmware Date          Wed Oct 14 18:33:28 EDT 2015
Firmware Version       v18D v4 
Bootloader             L1TC000118D0
status-b2g-master: affected → verified
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.