Do not pass the results class to the test runner

RESOLVED FIXED in Firefox 44

Status

()

Core
JavaScript: GC
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: terrence, Assigned: terrence)

Tracking

Trunk
mozilla44
Points:
---

Firefox Tracking Flags

(firefox44 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8671672 [details] [diff] [review]
only_pass_the_progressbar-v0.diff

Now that the jstest runner is a generator, we are no longer sinking tests directly to the results struct. As such it is unused except for the progressbar. Simple enough to pull it up one level. This also fixes a comment and re-adds the progressbar poking behavior to stop me from checking htop constantly.
Attachment #8671672 - Flags: review?(sphink)
Comment on attachment 8671672 [details] [diff] [review]
only_pass_the_progressbar-v0.diff

Review of attachment 8671672 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/tests/lib/tasks_unix.py
@@ +138,5 @@
>  def reap_zombies(tasks, timeout):
>      """
> +    Search for children of this process that have finished. If they are tasks,
> +    then this routine will clean up the child. This method returns a new task
> +    list that has had the ended tasks removed, followed by a the list of

"a the"
Attachment #8671672 - Flags: review?(sphink) → review+
https://hg.mozilla.org/mozilla-central/rev/b73011c19ef7
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox44: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1177551
You need to log in before you can comment on or make changes to this bug.