[Spark] Remove Customizer, Customizer Launcher, Sharing, Studio, Webmaker from the Spark build

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Build
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: drs, Assigned: julienw)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

3 years ago
These apps have outlived their useful lives, and we will be removing them from the Spark build. The Spark distro will live on for some time as a "foxfooding" distro. We will rename it as such when we have support for this from RelEng.
(Reporter)

Updated

3 years ago
Blocks: 1207371
Created attachment 8671687 [details] [review]
[gaia] DouglasSherk:1213113-spark-apps > mozilla-b2g:master
(Reporter)

Comment 2

3 years ago
Created attachment 8671689 [details] [diff] [review]
[gaia] Remove Customizer, Customizer Launcher, Sharing, Studio, Webmaker from the Spark build.
(Reporter)

Comment 3

3 years ago
Created attachment 8671690 [details] [review]
[spark] Remove Customizer, Customizer Launcher, Sharing, Studio, Webmaker from the Spark build.
Attachment #8671690 - Flags: review?(nhirata.bugzilla)
(Reporter)

Updated

3 years ago
Attachment #8671689 - Attachment description: Remove Customizer, Customizer Launcher, Sharing, Studio, Webmaker from the Spark build. → [gaia] Remove Customizer, Customizer Launcher, Sharing, Studio, Webmaker from the Spark build.
(Reporter)

Updated

3 years ago
Attachment #8671687 - Flags: review?(jdarcangelo)
(Reporter)

Comment 4

3 years ago
Comment on attachment 8671687 [details] [review]
[gaia] DouglasSherk:1213113-spark-apps > mozilla-b2g:master

Hackerplace is being replaced by Marketplace next week. Let's wait until then and also remove Hackerplace from the Spark distro.
Attachment #8671687 - Flags: review?(jdarcangelo)
(Reporter)

Updated

3 years ago
Attachment #8671690 - Flags: review?(nhirata.bugzilla)
Doug, 

Is this being taken care of for Spark build bug 1207371?
Flags: needinfo?(drs)
(Reporter)

Updated

3 years ago
Flags: needinfo?(bugzilla)
(Reporter)

Updated

3 years ago
Assignee: bugzilla → nobody
Status: ASSIGNED → NEW
(Assignee)

Comment 6

2 years ago
Maybe we also should turn off the "developer mode" pref in the same time ?
Blocks: 1229040
Created attachment 8710444 [details] [review]
[gaia] julienw:1213113-remove-spark-apps > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Assignee: nobody → felash
(Assignee)

Updated

2 years ago
Attachment #8671687 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8671689 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8671690 - Attachment is obsolete: true
(Assignee)

Comment 8

2 years ago
So I tried to update using my patch from a build without my patch. The first time I think it worked, except for the Webmaker app. But then I tried twice again and all the apps are still here.

I checked the update.zip I have, the apps are not in the zip. Yet they're still on the device after "adb sideload".

So maybe I do something wrong. I'll check with Alexandre directly on monday.
Thanks Julien, in case the problem is just with the Webmaker app, we could just focus on removing the Studio app.
(Assignee)

Comment 10

2 years ago
I would have chosen this solution too.

However as I said in my second try all apps stayed on the device :/
(Assignee)

Comment 11

2 years ago
OK, now I know why that happens: because my Gecko was the same, the app updater in Webapps.jsm didn't start.
When I force this updater code to run, the apps disappeared from homescreen (except Webmaker, but see below).
Yet the files are still in /system/b2g/webapps, I'm gonna try and see if I can remove them.

Reading the code in Webapps.jsm I also now understand why Webmaker won't be able to be removed: because our preloader mistakenly set hosted apps as "removable" apps, like apps that the user installs himself. So the system thinks the user installed Webmaker himself and we don't want to remove any such app.

So I think we can actually move forward with this patch now. Who can
(Assignee)

Comment 12

2 years ago
I tried to update with an update.zip containing full images (result of "build.sh gecko-update-fota-fullimg") and this removes the old apps from /system/b2g/webapps, so all good. If this is the type of OTA we do these days, then it's fine.

Last thing i want to do is update using a normal OTA (result of "build.sh gecko-update-full") and see what happens. Alexandre told me we either use a normal OTA or a FOTA with full images, so that's why I want to try both.

I'm not sure I'll be able to do it next week though as I'll take part to a workweek.

Comment 13

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.